[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Buster installer and speech issues



Didier Spaier, le mer. 24 avril 2019 12:20:08 +0200, a ecrit:
> On 23/04/2019 23:40, Didier Spaier wrote:
> > On bare metal, no luck: the installer could not detect
> > my sound card, so no  speech in the installer.
> > 
> > It made 9 unsuccessful attempts, told it would tried
> > other cards, seemed to gave up.

What do you mean by "told it would tried other cards"? What _exactly_
did it write? Otherwise I'm not sure what exactly you refer to, that's
how a way for me to be able to debug anything.

> > I have only one sound card.
> > 
> > That's weird as I have no issue with Slint's installer,
> > also using espeakup.
> 
> My assumption is that' there is an issue with S38espeakup.
> 
> If I understand well, you modified it to wait that
> /sys/class/sound/card*/id be populated.

Yes, because as commented there it seems that the Buster audio drivers
take _ages_ to initialize...

> I thought, maybe there's an issue with this modification.

Possibly, but I need precise information to be able to guess what is
going wrong. Please really post what is asked on 

https://wiki.debian.org/accessibility#Debian_installer_accessibility

from *within the installer* because that is what the script uses. The
alsa-info output from an installed system can be useful, but much less
than the precise information of what is _actually_ happening.

> PS FYI I attach the script used for card detection in the
> current Slint installer. Obviously it is a modification of
> S38espeakup (but a former version).

And it'll just fail the same way as Buster in case Slint happens to meet
the same driver initialization time.

Samuel


Reply to: