[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Using Orca in KDE



On Sun, Apr 06, 2014 at 06:40:26AM EST, Odd Martin Baanrud wrote:
> Hello,
> 
> I want to test Orca in KDE.

KDE so far as I know, is currently based on QT 4.8, with development of KDE moving to 5 in the future. QT 4.8 Linux accessibility support is rather bare bones. Some things do work, but many important pieces of functionality like interracting and working with text entry fields does not. All current QT Linux accessibility efforts are on QT 5 now, and 4.8 is only likely going to see important bug fixes for what is already there.

Fortunately, QT 5 ships the QT at-spi plugin out of the box, and from my early testing, works quite well. More testing is still needed however, since there are still many rough edges.

Luke


Reply to: