[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#741136: marked as done (brltty: Very unstable in Debian Installer 7.4)

Your message dated Fri, 14 Mar 2014 01:34:45 +0100
with message-id <20140314003445.GI6188@type.youpi.perso.aquilenet.fr>
and subject line Re: Bug#741136: brltty: Very unstable in Debian Installer 7.4
has caused the Debian Bug report #741136,
regarding brltty: Very unstable in Debian Installer 7.4
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

741136: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741136
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: brltty
Version: 4.4-10+deb7u1
Severity: important

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
I did a fresh install of Debian 7.4, in text mode.

   * What exactly did you do (or not do) that was effective (or
I enabled brltty with the "brltty=..." parameter.
I'm using a Handy Tech Braille Star 40 via USB, so I used "ttyUSB0" as the braille device.
This has always workd.

   * What was the outcome of this action?
When the clock was beeing configured, brltty crashed.
First I thaught it could be the machine, so I restarted the installer.
But the same thing happend, at the same stage.
Then I guessed that it was brltty.
I switched to the tty2 console, and got brltty re-enabled.
But it keept restarting over and over when I continiued the install.
It was almost impossible for me to read anything at all.
Every time I scrolled the display, brltty restarted.

It seems to me that this is a problem on amd64.
I did a install on a i386 machine earlier that day, and it worked without any problems.

-- System Information:
Debian Release: 7.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages brltty depends on:
ii  libbrlapi0.5  4.4-10+deb7u1
ii  libc6         2.13-38+deb7u1
ii  libgpm2       1.20.4-6
ii  libicu48
ii  libncursesw5  5.9-10
ii  libtinfo5     5.9-10
ii  lsb-base      4.1+Debian8+deb7u1

Versions of packages brltty recommends:
ii  python  2.7.3-4+deb7u1

Versions of packages brltty suggests:
pn  brltty-speechd   <none>
pn  brltty-x11       <none>
pn  console-braille  <none>

-- Configuration Files:
/etc/brltty.conf changed [not included]

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 5.0-1


Odd Martin Baanrud, le Sun 09 Mar 2014 00:23:17 +0100, a écrit :
> When the clock was beeing configured, brltty crashed.

I really believe this is due to some clock shift that previous versions
of brltty couldn't deal with. This has been fixed in brltty 4.5 and
5.0, and I've tested it successfully with a d-i built with brltty 5.0.
Unfortunately the changes are quite invasive, so I don't think we can
afford backporting them to Debian 7.  I'm thus just marking the bug as
solved as of brltty 5.0.

The workaround in your precise case is to fix the hardware clock before
starting the installer.

Sorry we can't help further,

--- End Message ---

Reply to: