[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Speakup modules in squeeze

On Wed, 2009-10-14 at 03:12 +0200, Samuel Thibault wrote:
> > Those modules that may be needed at installation time will be added to
> > the linux-2.6 package, and the speakup modules are clearly among those.
> > I have added patches that put them under drivers/staging:
> > 
> > svn://svn.debian.org/svn/kernel/dists/trunk/linux-2.6/debian/patches/features/all/speakup/
> > Please review these
> So speakup-add.patch would always be a mere copy of speakup-source?

Yes, or you could drop speakup-source.

> Speakup-kbuild.patch seems just right and will probably never have to
> change.
> > and let the kernel team know whenever speakup needs to be updated.
> Mmm, couldn't linux-2.6 build-depend on speakup-source and just
> automatically import the source from there?

No, that just moves the problem we have now to linux-2.6.

> > Currently staging drivers are only built for x86 because
> > many of them are not really portable.  I think this is not the case for
> > speakup, so let me know if it should be built for more architectures.
> Speakup should build and work on basically all archs (it was tested on
> both 32 and 64bit platforms, and both little and big endians).



Ben Hutchings
For every action, there is an equal and opposite criticism. - Harrison

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: