[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Testing Debian Sarge M68K DVD with WinUAE

On Sun, Feb 10, 2013 at 06:12:18PM -0000, Mark wrote:
> Hi,
> I have been testing the latest beta versions of the WinUAE Amiga emulator.
> WinUAE works mostly fine on Wine/Linux. There is now 68030/040/060 MMU
> emulation, so being able to test Debian M68K/Amiga on any x86 PC is
> possible. I have come across an issue with the M68K 3.1r8 DVD ISO image
> though.
> When WinUAE is set to emulate an Amiga 4000 with ATAPI CD-ROM drive, it
> works fine. The check integrity option of the installer doesn't report any
> errors with the DVD #1 ISO.
> However with an emulated SCSI CD-ROM drive connected to Amiga 3000 SCSI or
> A2091 SCSI controllers, the installer aborts with an error when loading
> components from CD. Also the check integrity option reports an error.

Can you tell us a bit more about the actual error? On woody we had missing
/dev/sr[01] (and scd[01]) devices, which should be fixed in sarge

> There is only a problem when using the DVD ISO, not the CD #1,
> businesscard or netinst CD images.
> So my questions are:
>  - Has anyone ever tested installing from the Debian 3.1r8 DVD on a real
> Amiga with a SCSI DVD-ROM drive? Or on any other M68K platform with a
> SCSI DVD drive?

I don't think that I own a SCSI DVD drive, do these actually exist? Are
they affordable?
> - Which component of the Debian system contains the SCSI CD/DVD driver?
> I'd like to check the source, maybe that could provide some clues as to
> the cause of the problem, whether a bug in WinUAE or a deficiency in the
> Debian SCSI CD/DVD driver.

Maybe you can check some other discs to rule out problems with the m6k iso?


Reply to: