[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kullervo

On Thu, Jan 24, 2013 at 03:27:12PM +0100, Ingo J?rgensmann wrote:
> Am 24.01.2013 um 10:09 schrieb "Christian T. Steigies" <cts@debian.org>:
> >> You should preferrably use either LVM or BTRFS snapshotsto speed up deinstallation of build-dep packages. I've chosen LVM because I'm unfamiliar with BTRFS, which is the most recommended option for handling chroots. 
> > I am a bit familar with LVM. Can I use this on one partition only instead of
> > the whole disk?
> Sure. Just choose a partition for LVM and do a pvcreate /dev/sdXY, pvcreate & lvcreate. 

And the idea is with LVM I can quickly create snapshots for building, user
chroots, etc? How much space should a chroot then receive, how much should I
leave for the snapshots? The partiton I would use has 160GB.
> > So far I always used chroot in standard directories, but
> > debootstrap failed in the end with this:
> > W: Failure trying to run: chroot /data/chroot/buildd/sid mount -t proc proc /proc
> > W: See /data/chroot/buildd/sid/debootstrap/debootstrap.log for details
> > chroot: failed to run command 'mount': No such file or directory
> > I dimly remember that I have to mount the proc directory on the host system,
> > but this error message is not very helpful.
> Yes, I had the same error, but I don't remember how I worked around it. :-/

deboostrap is slooooow... it took four hours to get to the same point, and
fail again. I had mounted proc and sysfs before running debootstrap, but I
think the actual problem is that some libraries are missing in the chroot

root@kullervo:~>ldd /data/chroot/buildd/sid/bin/sh  
        libc.so.6 => /lib/m68k-linux-gnu/libc.so.6 (0xc0005000)
        /lib/ld.so.1 (0xd0000000)

neither of them is available in the chroot. Do I need to add those packages
manually? My debootstrap line is this:

debootstrap \
 --keyring=/usr/share/keyrings/debian-ports-archive-keyring.gpg \
 --variant=buildd sid \
 /data/chroot/buildd/sid http://ftp.debian-ports.org/debian/ 
> > [    0.000000] Ignoring memory chunk at 0x7000000:0x1000000 before the first chunk
> > [    0.000000] Fix your bootloader or use a memfile to make use of this area!

> Hmm, I guess kullervo has some additional onboard Fast-RAM (ZIP Chips). That can be up to 16 MB RAM. When you substract this amount from 128M - kernel space it would make up to 20 MB, resulting in roughly 107 MB usuable RAM. But why should amiboot or the kernel substract the onboard Fastmem from the accelerator card memory? 
> There seems to be some information about amiboot on ftp://ftp.uni-erlangen.de/pub/Linux/680x0/v2.0/boot/amiboot-4.0.README including information about memfile. I guess Geert can better comment on amiboot questions.

I will have a look later. But the kernel is ignoring some memory, maybe it
is this. Or the kernel uses too much, but this is only 5MB, the video uses 640K:

[    0.000000] Memory: 109452k/109452k available (2740k kernel code, 2372k data, 124k init)
[    0.710000] fb0: Amiga ECS frame buffer device, using 640K of video memory


Reply to: