[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: status of perl patch working around lack of TLS

Dominic Hargreaves dixit:

>FYI: the patch has now gone upstream in any case:
>Although if anyone has any strong feelings about it, do let us know.

How about this?

Hi Jesse,

our paths cross again (remember that CVS fan from LSM/RMLL?),
please apply the attached patch. I’ve tested that this works.

13:22⎜«neurodamage» mira, what's up man? I have a CVS question for you in #cvs
13:22⎜«neurodamage» since you're so good w. it │ «neurodamage:#cvs» i love you
13:28⎜«neurodamage:#cvs» you're a handy guy to have around for systems stuff ☺
16:06⎜<Draget:#cvs> Thank god I found you =)   20:03│«bioe007:#cvs» mira2k: ty
17:14⎜<ldiain:#cvs> Thanks big help you are :-)   <bioe007> mira|nwt: ty again
18:35⎜«alturiak:#cvs» mirabilos: aw, nice. thanks :o
18:36⎜«ThunderChicken:#cvs» mirabilos FTW!  23:03⎜«mithraic:#cvs» aaah. thanks
18:41⎜«alturiak:#cvs» phew. thanks a bunch, guys. you just made my weekend :-)
18:10⎜«sumit:#cvs» mirabilos: oh ok.. thanks for that
21:57⎜<bhuey:#cvs> yeah, I really appreciate help
18:50⎜«grndlvl:#cvs» thankyou            18:50⎜«grndlvl:#cvs» worked perfectly
20:50⎜<paolo:#cvs> i see. mirabilos, thnks for your support
00:36⎜«halirutan:#cvs» ok, the obvious way:-) thx
18:44⎜«arcfide:#cvs» mirabilos, I am running OpenBSD.     18:59⎜«arcfide:#cvs»
Hrm, yes, I see what you mean. 19:01⎜«arcfide:#cvs» Yeah, thanks for the help.
21:33⎜«CardinalFang:#cvs» Ugh.  Okay.  Sorry for the dumb question.  Thank you
21:34⎜<centosian:#cvs> mirabilos: whoa that's sweet
21:52⎜«garrett__:#cvs» much appreciated  «garrett__:#cvs» thanks for your time
23:39⎜<symons:#cvs> this worked, thank you very much 16:26⎜<schweizer:#cvs> ok
thx, i'll try that     20:00⎜«stableable:#cvs» Thank you.    20:50⎜«s833:#cvs»
mirabilos: thanks a lot.        19:34⎜<bobbytek:#cvs> Thanks for confirming :)
From d21f8737820744012a88df3d70d6a215833566c6 Mon Sep 17 00:00:00 2001
From: Thorsten Glaser <tg@debian.org>
Date: Wed, 8 Jun 2011 21:36:08 +0200
Subject: [PATCH] There is TLS support on Debian/m68k, but the architecture is slow.

Revert 4a278ec85c28bdfcfeffd327eb483181131afb8e (re-enable the
stress.t and waithires.t tests) and raise the timeout on m68k
(not just Linux-m68k) for the stress.t test, since it passes,
but takes a long time to do so and produces a load avg of 40.

Signed-off-by: Thorsten Glaser <tg@debian.org>
 dist/threads-shared/t/stress.t    |   13 +++++--------
 dist/threads-shared/t/waithires.t |    6 ------
 2 files changed, 5 insertions(+), 14 deletions(-)

diff --git a/dist/threads-shared/t/stress.t b/dist/threads-shared/t/stress.t
index e126a21..1d49c54 100644
--- a/dist/threads-shared/t/stress.t
+++ b/dist/threads-shared/t/stress.t
@@ -11,14 +11,6 @@ BEGIN {
         print("1..0 # SKIP Broken under HP-UX 10.20\n");
-    # http://lists.alioth.debian.org/pipermail/perl-maintainers/2011-June/002285.html
-    # There _is_ TLS support on m68k, but this stress test is overwhelming
-    # for the hardware
-    if ($^O eq 'linux' && $Config{archname} =~ /^m68k/) {
-        print("1..0 # Skip: m68k doesn't have enough oomph for these stress tests\n");
-        exit(0);
-    }
 use ExtUtils::testlib;
@@ -44,6 +36,11 @@ use threads::shared;
     my $TIMEOUT = 60;
+    # This hardware is very slow, raise the timeout
+    if ($Config{archname} =~ /^m68k/) {
+        $TIMEOUT = 1200;
+    }
     my $mutex = 1;
diff --git a/dist/threads-shared/t/waithires.t b/dist/threads-shared/t/waithires.t
index 44c4bf9..3fe14ee 100644
--- a/dist/threads-shared/t/waithires.t
+++ b/dist/threads-shared/t/waithires.t
@@ -16,12 +16,6 @@ BEGIN {
     if (! eval 'use Time::HiRes "time"; 1') {
         Test::skip_all('Time::HiRes not available');
-    if ($^O eq 'linux' && $Config{archname} =~ /^m68k/) {
-        print("1..0 # Skip: no TLS on m68k yet <http://bugs.debian.org/495826>\n");
-        exit(0);
-    }
 use ExtUtils::testlib;

Reply to: