[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Loopback block device missing in hdinstall initrd?

Hi Diego,

On Wed, 7 Oct 2009, diego wrote:

> Hi,
> been trying to install etch-68k on a Powerbook 190. Kernel 2.6 that 
> comes on the netinstall iso image boots fine with ramdisk, xcept for 
> SCSI not working, so no CD-ROM drive. That's why I copied the iso to the 
> ide drive. The installer finds the iso there but can't mount it, tried 
> mounting manually and looks like there is no loopback block device in 
> the kernel. No module on the initrd either....Is there a way you could 
> include the loopback device driver (either in kernel or as module on the 
> initrd) for the hdinstall to work on scsi impaired 68k macs like mine?

I'll let the debian guys answer that one since I don't know whether there 
is a special kernel for the installer kernel or not (?)

I have a minimal config that I use for testing different machines, to 
limit RAM footprint and build time. It has sufficient features to run the 
debian installer, and boot from NFS and so on. It has the loopback driver 
built in. I've uploaded binaries for that and also binaries for a tweaked 
debian config at http://www.telegraphics.com.au/~fthain/linux-2.6.31/

I based the latter config on linux-image-2.6.29-2-mac_2.6.29-5_m68k.deb at 
debian-ports.org. I found that it was bloated by a lot of options that are 
not needed on this platform -- Serial Attached SCSI, USB, PS2 and FF input 
devices, LEDS, TPM, drivers for embedded devices, Gb ethernet etc. There 
are also a few options like IO scheduler that I think would be better as 

What's the best way to fix this? Are the debian m68k configs derived from 
the debian x86 config or perhaps from upstream? The upstream mac_defconfig 
is much slimmer (though I've never tried to boot it).


> Cheers,
> Diego Cousinet

Reply to: