[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Missing m68k builds for the point release


> Update: only pwlib and wesnoth were not ready when we released about two
> hours ago... They can still make it for the next point release which is
> planned for the end of february... Thanks for making sure the
> oldstable-security packages were ready and doing an effort to get as
> up-to-date as possible for the others!

Sigh - and we got this close :-)

> > So what did you do to get it to build now? apt-cache still fails in
> > mysterious ways for me (running the same command as sbuild assembles
> > internally, but from the console does get the data that sbuild never seems
> > to see).
> Nothing special, I just use sbuild -v -d oldstable wesnoth_0.9.0-8

That's what failed when I last tried it on crest. Stehen must've fixed it
in the meantime.

> > E: Opening /org/chroots/buildd/sarge/etc/apt/sources.list -
> > ifstream::ifstream (2 No such file or directory)
> > E: You must put some 'source' URIs in your sources.list
> >
> > Problem is, where does it pick up this path again? That's not where my
> > chroot is for unstable...
> That's just the /etc/apt/sources.list path in the chroot...

Nope, the sources.list path is given nowhere in any of the otions passed
to apt-cache the way sbuild assembles the command line.

> > Note to self: when copying around chroots, remember to update
> > /var/debbuild/apt.conf ... Sorry, I should have remembered that a lot
> > sooner.
> You mean for not complaining about not verified packages I guess?

It also has the path to the sources.list defined in there (and all that is
passed to apt-cache by environment).

> > Anyway, end of rant. It's building pwlib now. There's a perl build running
> > as well so it may be a bit slower than usually.
> >
> > Re: access to hobbes: I'll set that up as soon  as I have port forwarding
> > on the firewall set up. hobbes still has one major drawback for external
> > use: I can neither send nor receive mail via SMTP. Stupid Telecom NZ
> > firewalls that off, and does not provide instructions for using SMTP-AUTH
> > (or any mail gateway), either.
> I won't mind copying and running wanna-build manually :-)

Fine, we can set it up that way. With washi, I rigged my log reply scheme
to pipe the mail command through ssh, something like that could be used as


Reply to: