[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bts, t-p-u buildd, "testing problems", glibc 2.4...



I think glibc 2.3.999 needs some attention a some point:
http://experimental.ftbfs.de/build.php?arch=m68k&pkg=glibc

Well, glibc 2.5 currently in experimental should be buildable on m68k.
The number of places which required TLS have been small. Someone should test it, post result here and get buildd log into experimental.ftbfs.de.

BUT, post glibc-2.5 dropped completely support for non-TLS ready architectures. There are no more "#ifdef USE_TLS" in code.
Also linuxthreads are not supported for post glibc-2.5.
http://sourceware.org/ml/libc-ports/2006-10/msg00061.html,
even not in glibc-2.5 branch
http://sourceware.org/ml/libc-ports/2007-01/msg00056.html

So glibc needs serious attention from m68k porters ...

Petr



Reply to: