[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

3.1r1 still not installable due to CD-ROM not detected?

Hi all,

I have just tried installing 3.1r1 on ARAnyM and got the following error
box in d-i:

[!!] Detect and mount CD-ROM
Installation step failed

Lets compare it with the log at fourth console:

cdrom-detect: Searching for Debian installation media...
cdrom-detect: CDROM-mount succeeded: device=/dev/cdroms/cdrom0
cdrom-detect: Detected CD 'Debian GNU/Linux 3.1 r1a "Sarge" - Official
m68k Binary-1 (20051224)'
main-menu[215]: (process:407): find:
main-menu[215]: (process:407): /lib/modules/2.4.27/
main-menu[215]: (process:407): : No such file or directory
main-menu[215]: (process:407): WARNING **: Configuring 'cdrom-detect'
failed with error code 1
main-menu[215]: (process:407): WARNING **: Configuring 'cdrom-detect'

Any clue? The CD-ROM is mounted perfectly. It (mis)reported the failure
only because it didn't find path to kernel modules but WTF - that is
unrelated to CD-ROM detecting, isn't it? And why does it try to search
for that path, anyway? Is this a long-term bug in the ramdisk scripts?

I remember reporting this very problem in summer last year (or even
earlier) and was told that this would get fixed in next point release. I
thought the r1 would be the fixed one.



P.S. feel free to forward this to any more appropriate mailing list.

Reply to: