[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Results of various tests with MVME167

On Tue, Sep 07, 2004 at 08:26:07PM +0200, Kars de Jong wrote:
> So, I decided to take a kernel from daily d-i builds,
> vmlinuz-2.4.27-mvme16x. Oddly enough, this kernel crashed with the same
> error message...
> But I did have a working 2.4.26 kernel which I built myself.
> Then I tried vmlinuz-2.2.25-mvme16x. This did work fine.
> So I built the kernel based on my old config, and voila, it
> worked fine...
> Now it was time to find out which config option caused the problem...
> Took me quite some recompile/reboot cycles, but it turned out to be
> CONFIG_SINGLE_MEMORY_CHUNK. If this is NOT defined as "Y", the kernel
> crashes. And this is apparently also true for 2.4.x (x > ??) kernels.
> Seeing that the NCR53C710 bugs out with "illegal instruction" it would
> almost have to be a virt <-> phys conversion issue.
> Anyone else having problems with this?

Found it under advanced options. Do we need this only for mvme16x or for
other systems as well? Any other advance option, or only this?

You are saying we need to build 2.4.27 with this too? What about 2.4.26,
does that debian version work?

I don't have a problem to activate this option, if it does not hurt anybody.
But it will be a challenge to get this into the archive for 2.4.27...


Reply to: