[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: testing kernel-image 2.6.8-amgia



Hi Christian,

responses embedded.

On Tue, Aug 31, 2004 at 08:21:31AM +0200, Christian T. Steigies wrote:
> On Mon, Aug 30, 2004 at 10:52:11PM -0500, Lance Tagliapietra wrote:
> > Hello,
> > 
> > I grabbed kernel-image-2.6.8-amiga_2.6.8-1_m68k.deb from
> > http://people.debian.org/~cts/debian-m68k/kernel-image/ and tried it out
> > on my Amiga 2000 with GVP 030 card w/16M + scsi. 
> > 
> > I was not successful with this kernel.  Notes so far:
> > 
> > 1. I installed the archive via dpkg -x as root user from the /
> > directory. Is this the recommended way?
> 
> I recommend wajig, others apt-get. dpkg is fine, too, usually.
[...]
> 
> Did you install module-init-tools? Without this package, you don't have any
> modules, and usually no networking. The deb hould have a depends on this
> package, so you should not be able to install it without this. But maybe you
> convinced dpkg to install it, oh, wait a minute dpkg -x? No, that is
> definetely not recommended, dpkg -i, you want to install it! Who told you
> about -x? Thats the reason we have a kernel package, you install it like any
> other package, it looks out for depends, creates symlinks, runs some
> scripts. dpkg -x can overwrite important files, making your system instantly
> unusable. You can unpack in a local directory, if you just want one file,
> like vmlinuz for example, but never NEVER do this in /. You loose your
> warranty when you do it, when you just think about it!

Well, as for dpkg -x, give a guy a man page and he'll read it. And even
try some of the commands/options described in it!  When I did a dpkg -i,
it did complain about the missing dependency of module-init-tools.  I
didn't see this mentioned as a requirement on your WWW page with the
experimental kernel packages.  Since this was an experimental package,
I thought I would just ignore the warning and go on and see what would
happen.  If nothing else, there are now more data points of what it
looks like when things go wrong.  :)  Thanks for the warning about the
possible pitfalls.  Normally I do the -i (install), and this was a
unique case.

Before forcing the install, I did review of the files that would be
installed (dpkg -c) and observed that nothing is going to write over an
existing file.  Most of the files have "2.6.8" in the name which does
not conflict.

So it seems that module-init-tools is a 2.6 (Sarge?) requirement than it
is a 2.4 (Woody?) requirement.

Ah, and apt-get install  module-init-tools returns an error, E: Package
module-init-tools has no installation candidate.  Note that I don't have
unstable or testing as an apt-get target.  You might want to add this
package to your kernel install page.

I'll pull the module-init-tools and give it another shot.

General question: Can a kernel pick the /etc/modules file based on its
version?  For example, can I create a /etc/modules-2.6.8-amiga which
would be selected before /etc/modules as a default?  On my 2.4.27 I have
clgen compiled in, for example, so I don't need to specifiy it in a
modules file like I would to help test the 2.6.8 kernel.  My apologies
if this is a FAQ.

--Lance

> 
> > 6. The boot continued to a console login window.  When I tried to enter
> > username/password, I discovered that the key mappings were, um, bizarre.
> > Now, note that I'm trying to boot the 2.6.8 into a working 2.4.27
> > environment.  Perhaps there is a new keymap file I need to select (hint
> > please)?
> 
> There was something about keyboard issues (on a mac) on this list during the
> weekend.
> 
> Christian



Reply to: