[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: testing kernel-image 2.6.8-amgia

On Mon, Aug 30, 2004 at 10:52:11PM -0500, Lance Tagliapietra wrote:
> Hello,
> I grabbed kernel-image-2.6.8-amiga_2.6.8-1_m68k.deb from
> http://people.debian.org/~cts/debian-m68k/kernel-image/ and tried it out
> on my Amiga 2000 with GVP 030 card w/16M + scsi. 
> I was not successful with this kernel.  Notes so far:
> 1. I installed the archive via dpkg -x as root user from the /
> directory. Is this the recommended way?

I recommend wajig, others apt-get. dpkg is fine, too, usually.
> 2. Amiboot would not decompress the kernel without error.  I had to gzip
> -d the kernel image in /boot and copy to the Amiga paritition to boot.
> I did learn here that kernels are compressed with gzip during the normal
> make process.  I'll grab the specific Amiboot error message next time.
> I do remember reading about this issue before, hence why I tried the
> uncompress kernel image.
> 3. I first tried to boot with the console on my EGS Spectrum card.  This
> did not work, and I later noticed that the clgen support is via a module
> that I did not have in my /etc/modules.  I'll try that again later.
> 4. The kernel did boot, but since the clgen module was not loaded, my X
> console support was not available.
> 5. The tftp support was not thier either, as I could not get my
> X-Terminal to find its boot files from the Amiga.  Possibly not any
> networking?  I use a 2065 card, which is set up as a module from
> /etc/modules to indicate loading.  I would have expected this module to
> load.  Telnet in didn't work either.

Did you install module-init-tools? Without this package, you don't have any
modules, and usually no networking. The deb hould have a depends on this
package, so you should not be able to install it without this. But maybe you
convinced dpkg to install it, oh, wait a minute dpkg -x? No, that is
definetely not recommended, dpkg -i, you want to install it! Who told you
about -x? Thats the reason we have a kernel package, you install it like any
other package, it looks out for depends, creates symlinks, runs some
scripts. dpkg -x can overwrite important files, making your system instantly
unusable. You can unpack in a local directory, if you just want one file,
like vmlinuz for example, but never NEVER do this in /. You loose your
warranty when you do it, when you just think about it!

> 6. The boot continued to a console login window.  When I tried to enter
> username/password, I discovered that the key mappings were, um, bizarre.
> Now, note that I'm trying to boot the 2.6.8 into a working 2.4.27
> environment.  Perhaps there is a new keymap file I need to select (hint
> please)?

There was something about keyboard issues (on a mac) on this list during the


Reply to: