[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Testing 2.4.x or 2.6.x kernels on Amiga


please find my reply in the copy of your message below.

On 27.08.2004, you wrote:

> Moin, 
> On Fri, Aug 27, 2004 at 10:32:24PM -0500, Dr. Peter Krummrich wrote:
>> The description sounds good. One question that came to my mind - what can
>> I do, if the new kernel does not boot, i.e. how can I return to my old
>> kernel? Can I just boot the old one using amiboot and the old vmlinuz
>> file on my Amiga partition (are the appropriate modules, config and
>> system map still there)?
> Sure, as long as the package has a different name, the modules will also
> be in a different location. Ie in your case you have 2.2.20, no problem to
> install 2.2.25, 2.4.25, 2.4.26, 2.4.27 and 2.6.8 next to it. Actually the
> recent kernel-images also have the subarch name included, so you could
> install the official 2.4.27-amiga, and build you own 2.4.27. No conflicts.
> Actually, that's what I use the shift keys in my zsh config for ;-) But i
> don't really boot that often, to make big use of it.
> If you need more versions of one kernel-version version, just set EXTRAVER
> in the kernel-source Makefile to a unique identifier.
> Christian

Well, with these good news in mind, I tried to install a new kernel. Here is
what I experienced.

At first, I just tried to type the command:

apt-get install kernel-image-2.4.27-amiga.

The result was that apt did not find the package. So far, I had only the six
CDs from Woody R2 in my sources.list. I guessed that the package may be
present in the testing distribution on debian servers. So I added the
following line to my sources.list to include the testing distribution:

deb http://debian.tu-bs.de/debian/ testing main non-free contrib

After this, I tried to update the list of available packages by typing:

apt-get update.

Unfortunately, the scripts had problems with merging the lists of available
packeges. The following error messages were displayed:

Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing xtel (NewVersion1)
E: Problem with MergeList
E: The package lists or status file could not be parsed or opened.

Did I run out of memory/swap space or is this a problem with the programs
involved in the merging process? I have 64MBytes of RAM and a swap
partition of 200 MBytes. Are these package files really that big?

Anyway, in order to circumvent this problem, I deleted the six CDROM entries
in my sources.list, just keeping the line with the internet address and
redid apt-get update.

This time, the scripts terminated without error.

Next thing I typed was:

apt-get install kernel-image-2.4.27-amiga.

I was told again that apt-get did not find the package.

So I tried kernel-image-2.4.26-amiga. This worked. I managed to copy the
kernel image to my Amiga partition and to reboot with the new kernel.

I mainly observed two things - the first beeing that the new kernel indeed
comes with a different version of clgen -, that is. Unfortunately,
I got the same problems as with the old clgen (v1.4 ?). Scrolling still
inverts pixels in the lines that are scrolled in some cases. The problem is
especially severe when changing to a different resolution (I tried
1024x768-70 using fbset). In this mode, all scrolled lines are completely
messed up. It is no problem with my monitor - the bottom line is still

Another thing I observed was that the new kernel did not load the Ariadne2
module (did not find it). The 2.2.20 kernel does not have this problem. The
Ariadne2 module works fine with my X-Surf ethernet card, so I don´t want to
miss it.

So I decided to go back to kernel 2.2.20, which gives me a better
performance so far. Fortunately, you were right that everything is still in
place for the old kernel if a new one is installed. I did not have problems
to boot into 2.2.20 after testting 2.4.26.

I have copied the messages from clgen (the version from the 2.2.20 kernel)
that are displayed during the boot process:

clgen: Driver for Cirrus Logic based graphic boards, v1.4 ?
clgen: Picasso II board detected;  RAM (2 MB) at $200000,  REG at $ec0000
clgen: This board has 2097152 bytes of DRAM memory
Console: switching to colour frame buffer device 80x30
fb1: Amiga ECS frame buffer device, using 640K of video memory

Maybe someone with experience with clgen can take a look at them and tell me
if he sees something strange. I am still wondering what I can do to get
around the problems with the graphics driver. Seems to be a software
problem, as the same hardware works perfectly under AmigaOS (no flickering
pixels, no inverted pixels when text is scrolled,...).

Any clues?

Sorry for the long message.


Reply to: