[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re :Re: Kernel 2.6 for m68k/amiga

On Wed, Aug 18, 2004 at 10:25:48AM +0200, Geert Uytterhoeven wrote:
> >
> > Jul 17 22:38:03 aahz kernel: zorro8390: Unknown symbol ei_open
> And at least ei_open is exported by drivers/net/8390.c...
> Was 8390.o loaded? If not, can you try to load it manually, so we know it's a
> bug in the dependency checker of module-init-tools or in the in-kernel module
> loader?

I am having a hard time using the console on the Amiga, not only because the
keyboard is having troubles (can't type f or TAB anymore), but also because
it is nearly impossible to see anything with the flifi mostly broken. Can I
add 8390 to modules.conf, or is there some other file responsible for module
loading on 2.6? I only installed module-init-tools yesterday, I didn't read
any manuals. Works on my P2 where I installed sarge and later a 2.6 kernel.
I guess the kernel-images need a dependency on module-init-tools as well...
Maybe I should set up a serial console?

> > I am now running 2.4.27, and I found the cause for my problem with 2.4.26,
> > which is also in 27, I need to turn off ECN:
> >
> > echo 0 > /proc/sys/net/ipv4/tcp_ecn
> >
> > Otherwise I can not download packages or access websites.
> Ugh, still behind a router/firewall that rejects packets with the ECN bit set?

I brought my Siemens router with me from the US, works nicely when you give
it 110V. Haven't tested the Linksys wlan router much yet, maybe that one does
not have those problems. But since the wireless bridging does not work as I
hoped, I wont be using it much...

> I've been living with ECN enabled (oops, my new home machine seems to have it
> disabled) for a few years...

I only activated in in 2.4.26, I forgot why. But it seems I am the only one
having problems with it, but at least it is run-time fixable.


Reply to: