[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Atari bootstrap

Petr Stehlik <pstehlik@sophics.cz> writes:

> Andreas and Stephen, I understand from your words that the unability to
> open an initial console is something fatal. But I keep getting this
> message everytime I boot the Woody's root.bin (which continues to
> operate normally, it seems).

I have no idea why you get the message.  The last time I tried booting my
TT with a ramdisk I didn't see the message and everything worked normally.

> What does it mean when the /dev/console cannot be open?

The message is printed in init/main.c:init(), just before /sbin/init is
executed, and means that fds 0/1/2 remain closed.  But since booting
continues normally, someone apparently succeeds to open the console
sometime later.  Without any information about why it fails initially I
see no way to explain the message.


Andreas Schwab, SuSE Labs, schwab@suse.de
SuSE Linux AG, Maxfeldstraße 5, 90409 Nürnberg, Germany
Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."

Reply to: