[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PowerBook 520c

Chris Tillman wrote:
> On Sat, Apr 13, 2002 at 09:27:48AM +0100, Sacred Eagle wrote:
> > Hello all!
> > I just received an old Mac PowerBook 520c and I wonder if it is at all possible to install Debian on it?
> > It doesn't have a CD device so have to make a floppy install. I've downloaded all the Debian (Potato) images (floppy) for PowerPC but I want to know if there is someone here who has done this before.Any advice/warnings before I make a go for it?
> According to my ancient Apple Spec chart, the 520c is a 68LC040 with a
> maximum of 36MB memory and a 240MB or 320MB hard disk (does that take
> you back or what? -- you could pay extra for an optional 80MB extra!).
> Anyway, potato would be a better choice for this machine, woody may be
> too memory and disk intensive. But you need the m68k images, not
> powerpc. You will need to leave MacOS on the machine, because m68k
> can't boot on its own; so that means your hard drive will need to be
> shared between a minimal MacOS and a minimal Linux. You'll need at
> least 100MB for Linux, that's probably not enough for an X server
> though.
> I'm forwarding to debian-68k to see if anyone else has comments.

Because of the forwarding I cannot find the mail-address of the original
author (Sacred Eagle), so I'm forwarding this to debian-powerpc too in
the hope that he'll receive it.

Congrats with the machine. There are a few hurdles to overcome with
Powerbooks in general:
1)	The ADB (Apple Desktop Bus for keyboard and mouse) type of Powerbooks
will only work with 2.4.x kernels. Get yours from
2)	Linux/m68k has troubles with most  68LC040 processors Apple bought
from Motorola because there's a bug in the CPU which prevents
floating-point emulation from working. There have been some people on
the linux-mac68k mailing list who wanted to recompile the complete
potato base system with --msoft-float (?). I think one was called
Matthew Eis. Please ask at linux-mac68k@mac.linux-m68k.org.
3)	Because debian potato and woody only have 2.2 kernels you'll maybe
need to take a few extra steps. One I'm certain is manually installing
2.4 modules. Don't know of any other.

Please don't be discouraged: the kernel-hackers and others at
linux-mac68k@mac.linux-m68k.org would really love to hear how everything
comes along.

Hope this helps, Erik
Erik C.J. Laan				elaan at dds.nl

To UNSUBSCRIBE, email to debian-68k-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: