[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debugging the m68k build

On Sun, 11 Mar 2001, Steve M. Robbins wrote:

> Hi,
> I'm the DD for geomview, and I'd like to have it get into the
> "testing" distribution.  M68k is one of the architectures
> for which the build failed, and I'd like to understand why.
> I had a look at the latest buildd log
>   http://m68k.debian.org/buildd/logs/geomview_1.8.0-5_20010305-1546
> and noticed that it is bombing out on the "configure" step.
> In particular, the motif header file "Xm/Xm.h" is not detected.  The
> package has a source dependency on "lesstif-dev", so that file *is*
> installed.  [On my machine, it lives in /usr/X11R6/include/Xm/Xm.h.]
> On my machine (i386), the configure script for geomview decides that
> "-I/usr/X11R6/include" is required to find the standard X headers
> (X11.h, etc).  But this does not happen for the m68k, it seems; the
> output from configure says:
>   checking for X... libraries /usr/X11R6/lib, headers 
> On other architectures, this step says
>   checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
> Anyone know why?  Can someone send me the "config.log" file created
> by this build?  
> I'm not a M68k person, so any insight into this is appreciated.
I've filed a bug (#61288, resolved) some time ago against lesstif-bin and
it turned out that package was built with different configuration on i386
(correct) and m68k (wrong). AFAIR it had to do with building from CVS on
i386 and not on m68k. Maybe it's the same issue with lesstif-dev (or your
package)? Perhaps ask Herbert Xu, the lesstif maintainer, he found out
what went wrong.


Bj"orn Brill <brill@fs.math.uni-frankfurt.de>
Frankfurt am Main, Germany

Reply to: