[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem upgrading to stable

On Tue, Feb 27, 2001 at 08:31:26AM +1100, Hamish Moffatt wrote:
> It appears to be 2.2.1-1.

OK, I've been working on it and I think the problems are caused
by ld-2.2.1.so.

Proof(?): I have woody in /usr/local/woody.

Start with /lib/ld.so.1 -> /lib/ld-2.1.3.so

Do the following (in sash!)

cp /usr/local/woody/ld-2.2.1.so /lib
cd /lib
rm ld.so.1
-ln -s ld-2.2.1.so ld.so.1
bash (segfaults)
-rm ld.so.1
-ln -s ld-2.1.3.so ld.so.1
bash (works fine)

But ld-2.1.3.so can't be used with the glibc 2.2.1, because
of the GLIBC_2.2 symbol which is missing.

Hamish Moffatt VK3SB <hamish@debian.org> <hamish@cloud.net.au>

Reply to: