[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.2.10 on Mac IIcx: SCSI doesn't work :-(

On 9 Aug 2000, David Huggins-Daines wrote:

> Michael Schmitz <schmitz@opal.biophys.uni-duesseldorf.de> writes:
> > > <SLAP!> Maybe I should actually _read_ the message before posting dumb
> > > responses =). Although, it's really the same thing. Basically, IIcx == IIx
> > > == SE/30, as far as the important hardware is concerned. I'd expect the
> > > IIcx to have the same problems as the SE/30- it also has the Mac II-style
> > > via's.
> > 
> > Something must have been broken horribly since I last tried a 2.2 kernel
> > on eithe SE/30 or IIcx somewhat more than a year ago. Maybe I'm just being
> > mean here but I'd suspect the interrupt rewrite. Was the SE/30 tested
> Uh oh.  A while back, I kind of blindly cleaned up the 5380 drivers
> (removing unused code, really ugly old hacks, etc) and committed it
> because it worked for me on the LC III.
> It's entirely likely that this is the cause of this.  You could try
> the old NCR5380.[ch] and macscsi_new.[ch] (or whichever one we were
> using) and see if that makes a difference.

I doubt that's what's going on. See my other message. I saw the logs of
your cleanups. They happened in fall '99, which was long after it was
already broken. Of course, if it broke it more, I wouldn't know. ;) But I
doubt it.

What the broken machines have in common is the style of via's. That makes
me suspicious of the interrupt code, not the SCSI code.


Reply to: