[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.2.10 on Mac IIcx: SCSI doesn't work :-(

On Wed, 9 Aug 2000, Alexander Shumakovitch wrote:

>   [ Please CC: me as I'm not subscribed to linux-mac68k@mac.linux-m68k.org ]
> On Wed, Aug 09, 2000 at 12:26:15AM -0400, Ray Knight wrote:
> > Alexander try the 2.2.16 kernel available from
> > ftp://macduff.dhs.org/pub/cvs/vmlinux-2.2.16-080600.gz this was built
> > using the latest CVS source from mac.linux-m68k.org which has had some
> > further work done on the 5380 SCSI driver.  Let us know the results on
> > the mailing list linux-mac68k@mac.linux-m68k.org
> I've tried it. Now the disk partition is being recognized correctly and system
> proceeds with Init. But not very long, unfortunately :-( After writing
>   Calculating module dependencies...
> ('depmod -a' was running) the kernel crashed and started to output tons of
> trace and stack information which scrolled away too fast to be recorded. I
> only could see repeating patterns of
>   Aiee, killing interrupt handler
>   Data write fault at [some changing hex number] in Super Data (pc=.......)
> In a couple of minutes it all stopped with the last words of kernel being:
>   Kernel panic: Attempted to kill idle task!
>   No interrupt handler - not syncing
> When I've tried to reboot, the same happened even earlier at the beginning of
> fsck test (as the partition was unclear unmounted). I guess this happens at
> the first try to write something to the disk, as when I didn't have
> appropriate modules on the computer (and depmod was exiting immediately) it
> all went further till network setup. I suspected the problem to be in the lack
> of modules, installed them, and got what I've just described.
> I've also tried as someone suggested vmlinux-2.2.14-073100.gz, but it didn't
> find SCSI at all and died quietly after writing
>   Mac68K Z8530 serial driver version 1.01
> That's all what I got up to now. 

I haven't seen this entire thread, so I apologize if I ask questions that
have been answered. What Mac do you have? Is it, perchance, an SE/30? The
SE/30 is not exactly in a nice, stable, working state at the moment. It
seems to top the list for total amount of broken stuff. :( I'm working on

I was able to boot my SE/30 with vmlinux-2.2.14-073100.gz, but I get the
same buserr with the 2.2.16. Don't know why yet, but I don't think it's
the pDMA code.

>   --- Alexander.
> PS Could someone point out to a FAQ about how to make a Mac-DB9 null-modem
> cable. I'm already fed up with writing that criptic kernel output down with a
> pen instead of simply loging on a serial console. Thanks in advance!

My advice: get another Mac. Any Mac. Every Mac serial printer cable is
wired as a null modem cable, so you can just hook a cable from one Mac to
another without any special adapter. I suppose you could add a DB9 adapter
to one end of the cable to hook to a PC, but I've never tried it.

The other nice thing about serial output is that some of the most
important messages show up before the main console ever comes up.


Reply to: