[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.2.10 on Mac IIcx: SCSI doesn't work :-(

Hi everybody!

Today I've tried to switch my Mac IIcx to running 2.2.10 kernel and got some
grave SCSI problems. Everything stops at the partition check. The last
messages which I see are:
  Partition check:
   sda:scsi : aborting command due to timeout : pid 10, scsi0, channel 0, id 0, lun 0 Read (6) 00 00 00 02 00
  scsi0 : aborting command
  scsi0 : destination target 0, lun 0
          command = Read (6) 00 00 00 02 00
  NCR5380 : coroutine isn't running.
  BASR: 10
  ICR: 00
  MODE: 00
  scsi0 : REQ not asserted, phase unknown.
  NCR5380 core release=7.
  Base Addr: 0x00000    io_port: 50f10000     IRQ: 19.
  NCR5380 : coroutine isn't running.
  scsi0: no currently connected command
  scsi0: issue_queue
  scsi0: disconnected_queue
  scsi0 : destination target 0, lun 0
          command =  8 (0x08)00 00 00 02 00

(all but the first 2 lines are repeated twice). 

Switching back to 2.0.36 solves the problem. Initial SCSI-hardware detection
messages look the same for both kernels, although I'm not 100% sure, as they
scroll away too fast. So here is what 2.0.36 thinks about the SCSI setup: 
  Macintosh SCSI: resetting the SCSI bus... done
  scsi0: at port 50F10000 irq 19 options CAN_QUEUE=16 CMD_PER_LUN=2 release=1
  scsi0: generic options AUTOSENSE generic release=7
  scsi0 :
  scsi : 1 host.
    Vendor: QUANTUM   Model: LP240S GM240S01X  Rev: 6.4
    Type:   Direct-Access                      ANSI SCSI revision: 02
  Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  scsi : detected 1 SCSI disk total.
  SCSI device sda: hdwr sector= 512 bytes. Sectors= 479350 [234 MB] [0.2 GB]
As was suggested somewhere, I've tried to add mac5380=1,1 kernel option, but
it didn't change anything (yes, 2.0.36 ignores it, but 2.2.10 doesn't, I've
double-checked that!).

Any clues? Any kind of help or reference would be greatly appreciated!

Thanks a lot in advance!

  --- Alexander.

Reply to: