[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian/Mac and serial ports


>dmesg will tell you for sure whether the kernel found the serial ports
I just sent what dmesg says in a separate message...doesn't say much
to me anyway, but it shows the ports being detected.

>the script definitely WILL run, I don't know how come it's not in

At boot, there is no message Initializing Serial Ports...someone
else suggested I should see that, and I know it used to happen in
Debian systems, on Intel anyway.  Not seen here with Debian/Mac.
Should I see that message or not?

>your case, it runs on my m68k box, and they all use the same base
>files. (I run 2 i386 pc's and a 68040 Amiga with Debian Linux)
>/etc/init.d/rcS contains -

>#       For compatibility, run the files in /etc/rc.boot too.
>[ -d /etc/rc.boot ] && run-parts /etc/rc.boot
Ok, thats where it should run then at boot time....and it does.  I
put that -vx in the script, and it does run.  But, the ports do not
work unless or until I use the config menu in minicom to jump start
them.  So, setserial is not doing what is needed to make them come
alive.  Minicom allows me to do that manually, and then they do in 
fact work.  Thanks for the tip as that proves it is being run, its
just not doing what is needed to get them going.

>You will get some extra output, ie. it will show you the lines it is
>executing as it is done.  This will be displayed to the console as
>you boot up.  Try it also in the rcS script.  If the rcS script isn't
>being run then your system probably has far worse problems than a
>serial port not working.
Actually, everything, which isn't much on this machine as yet, works
just fine I'm pleased to say.  There is no other issue that is in any way
a limiting factor that would suggest there are major problems somewhere.
That just is not the case I'm glad to say.  The only other issue is the
onboard ethernet (sonic) which I believe is not supported yet anyway.  
Otherwise Mac Debian works just fine thank you.  Including the ports, 
once I use minicom's config menu to get them started that is.  And once
I've done that, they work just fine too!

>The other thing is that setserial doesn't necessarily have to be run
>to initialise a serial port, however from the man page, you may use
>it to set/get Linux serial port information.
Yeah, the script actually even says that in a comment...but that does
not apply to Mac's apparently, since they don't work!  Not until I use
that config menu in minicom, that is.  That tells me they do, in fact,
need to be init'd somewhere during boot, otherwise they don't work, which
is not the case with other m68k machines, apparently, such as your Amiga.

The Mac ports apparently need something more done here, that isn't 
happening, and the /etc/rc.boot/0setserial doesn't get it done either.
Fortunately, using that minicom menu gets it done, and then they work.

I've also tried setserial /dev/ttyS0 spd_normal right after booting but
that isn't enough to get them lit up either.


Reply to: