[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian/Mac and serial ports

     As I mentioned earlier, I thought I'd get a chance to mess with
the serial ports and I'd let you know what I discovered.  I did, but
I remain confused from what I've found.  Here's why:

This time, I connected a modem to the Mac's modem port, which is ttyS0
under Debian, and used minicom to test it.  I didn't actually connect
to any service, but just used AT commands and such to see the port work
moving data in and out.

Well, this is the confusing part: the port refuses to work UNTIL the 
flow control is "toggled", then it will pass data.  Doesn't matter if
the port is initially set for hardware flow 'Yes' or 'No', it doesn't
work UNTIL it is toggled!

This drove me nuts!  I'd set it for hardware flow 'Yes', save that as
the default, turn the modem off, exit minicom, turn the modem on, run
minicom again, and it still won't work UNTIL the hardware flow is 
toggled 'no'.  Set it to 'no', go thru the whole process again, and it
still won't work UNTIL the setting is toggled to 'yes'!

Doesn't matter which is set as the default, it will not work UNTIL the
setting is toggled to the opposite setting!  Interestingly enough, it
can than be set back to the way it was originally, and it will still
work.  Doesn't matter which is set as the default, it must first be set
to the opposite before the port works.

I tried reprogramming my modem setup, disabling flow control, etc, and
nothing changed this behavior.

Now, I don't know from this whether it is minicom or if its the ports.
Its confusing, and I can't rationalize why its behaving in this way, but
thats what I've found.  The little external modem I used for this has a
full complement of led's so I could see whats going on.  No data in either
direction passes UNTIL the flow setting is toggled, regardless of how it
is initially set when minicom is launched.

I also tested it, using the Mac serial port as my serial console on a
Sun Sparc/IPX; which I mentioned I had tried before with no success.
Well, its the same.  The port will not pass data in either direction
UNTIL the setting for hardware flow is toggled.  Again, makes no 
difference if it is first set 'yes' or 'no', it must be toggled before
it will work!  Once it is, it works fine with either setting in this 

But, for use with the modem, I'd think you would want it to be 'yes'
regardless.  This means you'd want to set the minicom config to 'no'
then after starting minicom, use Meta O and select serial port, and
toggle hardware flow from 'no' to 'yes' (the F key does it).  Once you
do that, it'll work.  If you don't, it won't.

I can't explain this behavior, but that is what I've found.  Oh, this
is all with kernel 2.1.120 #14.  I didn't have a chance to run thru it
all with the 2.0.33 kernel.

Hope this is helpful...its wierd, but its what it is..


Reply to: