[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mac classic with scsi-ethernet?

> wo> I don't know for sure, but I wouldn't expect them to be supported,
> wo> since most internal on board ethernet's are not working yet either!
>Argh! So it's even a bit worse than I exptected...
Well yes, it seems so, but like I said, I've found the NuBus ethernet
card I have to work fine, but only with the 2.1.120 kernel #14. It is no
on the on board controller with any Mac that I have available here; so
> wo> The on board ethernet's do work, on most Mac's, under NetBSD, but
> wo> are not yet working with MacLinux.
>And there's no way of using or looking at the netbsd source?
>Reverse engineering macOS drivers is OK? Doubt it.
Yep, thats why I've mentioned NetBSD IS working with these, in hopes 
that the developer guys would see that. :)
>Hmmmz. So the ethernets that have some kind of support aren't working quite
>stable. :-/
Yes, this is an interesting mix to be sure.  For example, with the 2.0.33
kernel (#160 or #165), it does "see" both the NuBus ethernet card and the
builtin, but NEITHER work for anything except ping!  So, to me it seems 
that the error there might be the tcp layer itself has some fault, because
the 2.1.120 #14 kernel DOES WORK with the NuBus card!  And I've checked it
out by using Lynx on the Internet (thru my RH Linux 5.0 box as my 
masquerading router).  With that kernel, it all seems to work fine; 
ftp, Lynx, etc, but only with the NuBus card.

And this kernel does "see" the onboard ethernet at boot time, but every 
other time it hangs the boot process because it sees the MAC address of 
that controller as illegal, and it doesn't seem to know what to do, so it
just kills the boot right then and there.  On the next boot, it'll see it
and see that error again, but it doesn't kill the boot, so its kinda 
>Currently I only have a classic but soon I'll have a clasic II for the linux
>stuff. I need to get some disk(s) to replace the original 40/80M disks and
>(re)install macOS 7.0.1 on them.
I have installed a minimal Debian/68k on an old SyQuest 44MB disk.  The 
Debian is just the base obviously, but it does work!  I use a 8MB swapfile
and it has about 8MB free on it.  I did this so I could readily test it on
my other Mac's.
>Are there any problems with larger (1GB+) disks in classic macs? (like the
>weird pc 1024 cylinder limit, IDE 520Meg and other stuff)
I don't think so, but I don't know for certain since I have only one SCSI 
disk that large, and its on my Mac that I use as a server, so I haven't 
tried that with Debian.
>When macOS is working I can try Linux on the clasic II; I understand that 
>I can write some floppies to boot from and that an install is basically 
I don't think thats correct...the floppy drive doesn't work once you have
Debian installed...or at least I haven't figured it out yet.
>but what about the problem Fumio.Chisaka <chisaka@upu.wlw.co.jp> reported 
>about the installation messages being too wide for a 9" monitor?
>Is there a way to fix this? 
I have no idea on that score.
>When the system is working, what parts of the machine (kernel!) need 
>testing or improvement? I am quite new to macs but a portable linux 
>system can be quite handy especially when the network _is_ supported!
Hold on, the network DOES WORK, but not using the builtin controller,
and ONLY with kernel 2.1.120 #14, as far as my experience goes.  And
this only works for me with the NuBus Asante ethernet card.  The kernel
that comes in the install disk set is 2.0.33pl1 #160, and it does not
work.  Neither does 2.0.33pl1 #165; although they get close, since ping
does work, but nothing else, with either of those 2.0.33 kernels.
There is much that I haven't tried, but that is partly because I have
not downloaded alot of things.  So far, I have only minimal stuff on
Debian/Mac and part of that is because the distribution stuff doesn't
work, network wise, and that was my principle interest at first.  So
I got off trying to find the combination that did work as far as the
network goes.  And, as I said, it all does work with the NuBus card
and the 2.1.120 kernel #14.

But, since the installation stuff is all based on the 2.0 kernel (all
the modules are for that kernel), I haven't tried those things either.

Other than the problem with the builtin ethernet, the 2.1.120 kernel
I use (#14) also has a few other nuances, such as it will not properly
shutdown (or reboot).  If you give the command 'reboot' or shutdown -r
now, it spins everything down, but then traps with an Illegal Instruc.
The prompt there is the normal ^D for normal restart, which does nothing
except prompt you again, OR, give the root password to enter maintenance
mode (single user).  Giving the root password here does work, which puts
you into single user mode.  But, to actually reboot or shutdown, you 
must shut the power off at the prompt that results from the trap.

I don't think the serial ports work either, but I hesitate to say that
unequivocally since I haven't yet sorted it out with the three kernels
I have been using.  I've tried using minicom on Debian/Mac as a serial
console with my Sparc IPX, but had no luck with that, while the very
same Mac running either MacOS or NetBSD, this works fine.  I'll try
them again and let you know how it goes.  This time with a modem since
that should at least allow me to see characters back and forth if they
are working at all.  For some reason, when I did this using minicom the
first time, it ended up putting the Sparc back in console mode; ie, it
somehow generated a character sequence that put the Sparc, which had
been booted up running Red Hat Linux/Sparc, back into its machine monitor
and I don't even know how to do that from the keyboard!  Hic! ;)  Well, 
I really do; its Stop a, but I'm not sure what Escape code the Sun kybd
generates when its Stop key is pressed.  For those reasons, I hesitate
to say the ports aren't working, but I'll check further.

One thing I really like is the handling of MacOS filesystems from the
Debian side.  You just mount'em, and its there.  Cool!  And very nice
and useful too!

For example, the .deb's that I do have, I just leave on the Mac side.
Mount that partition from Debian, and dpkg -i blah_blah to install
them....cool!  This works much better than the hfsutils on NetBSD,
especially since I've never been able to make that work at all!

I'm not sure if you realize this or not, but with the variability of
the Mac hardware, and in particular its ROMs and LSI chipsets being so
different from model to model, I'd say these guys have pulled off a
minor miracle in pretty short order!  I've been using NetBSD on my Mac's
for some time, so I've become a little familiar with the difficulty in
dealing with those issues (not directly, but only from that exposure
with using NetBSD, not as a developer).  What makes it more difficult
is that Apple essentially refuses to provide much help with this sort
of effort either, with the exception of the MkLinux effort, and that
doesn't apply because thats PowerPC stuff, and even that is kept inside
Apple for the most part, as I understand it.  So these guys are really
doing it the hard way!

I don't know about you, but I'm thrilled to see Debian on my Mac!  I
go back aways with Debian, but I don't run it anymore on Intel, but
thats not because I don't like it, because I do.  It was my favorite
Linux for years!  And I only switched on Intel because of business.

But now having it on Mac, or almost, is great!


Reply to: