[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Bulk] Re: BD-RE - can't create UDF on new disc

On 19/08/12 09:02 AM, Thomas Schmitt wrote:

Mike Scheutzow wrote:
do you think that this user
could be having the well-known "udev polls the dvd" problem?
That can cause a block device to appear to be read-only.
Well if it does cause such effects then it is surely worth a
try to disable it.

udev and hald are the natural enemies of burn programs.
We compete for the same hardware and the OS normally does not
care about arbitrating.
Nevertheless, i would have expected that the block device
driver gets more respect by udev.

Here's one hit from google
(different symptom, but solution would be the same):
It advises to try:
   udisks --inhibit-polling /dev/dvd
   udisks --inhibit-polling /dev/sr0

Do you have more information about udev causing read-only optical
media ?

Have a nice day :)


Tried that. With no media in the drive, I started udisks then inserted a blank disk and tried to mkudffs on it (in a different root terminal). It failed with the same read-only error.

Reply to: