[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: BD-RE mount problem

On 09/08/12 12:08 PM, Thomas Schmitt wrote:

[i am subscribed to cdwrite@other.debian.org, not to debian-user]

I tried a new disc again, and this time formatted it through K3B
instead of using dvd+rw-format directly.
I don't know what K3B does as "formatting", but dvd+rw-format does
only a hardware level formatting. It does not create a filesystem.

Further to above, I did a file copy using K3B onto one of the BD-RE
discs that won't mount. K3B appeared to recognize that there was a
udf file system on the disc.
I would rather expect that it created one around the files which
you told it to copy.

After it finished, it automounted as /media/cdrom0 with fs type
So it is probably an ISO 9660/UDF hybrid filesystem created by
mkisofs (which was started under the control of K3B).

However, I can't mount it -rw. It insists that the file system is
This is not the variant of UDf which you want.
You want a read-write filesystem.

root@transponder:/home/garydale# mkudffs /dev/sr0
Error opening device: Read-only file system
This should have worked.
Do you have no w-permission to /dev/sr0 ?

I just exercised with success:
   mkudffs /dev/sr1
   mount /dev/sr1 /mnt
   cp /some/dir /mnt
   umount /mnt

INQUIRY:                [HL-DT-ST][BD-RE  GGW-H20L ][YL03]
  Mounted Media:         43h, BD-RE
  Media ID:              VERBAT/IM0

(Not that i ever would do that for backup. The umount time alone gives
  me creeps. No chance to get full write speed. Arrrgh !!!
  I use my own ISO 9660 multi-session tool xorriso for backups.)
Yes, I have read-write permissions. I tried xorriso to fix the disc as well but it also fails.

   root@transponder:/home/garydale# dvd+rw-format -force=full /dev/sr0
   * BD/DVD±RW/-RAM format utility by<appro@fy.chalmers.se>, version 7.1.
   * 24.2GB BD media detected.
   * formatting .:-[ FORMAT UNIT failed with SK=5h/INVALID FIELD IN
PARAMETER LIST]: Input/output error
It would be interesting to see what paramaters the program sent
with the FORMAT UNIT command. According to the source code it would
be Format Type 0x30 with sub-type 2.
This should not cause an error.
I've seen mention of this in some of my google searches on the various messages I've been getting. Can you elaborate on how to change the format type from the command line?

Here's the dvd+rw-mediainfo:

root@transponder:/home/garydale# dvd+rw-mediainfo /dev/sr0
  formatted:             11826176*2048=24220008448
Well, it is already formatted. That should suffice for a whole
media life. The problem is to get mkudffs to work.

Maybe it is reluctant to overwrite a valid ISO 9660 or UDF on the
medium ?
Try to overwrite it by brute force
   umount /dev/sr0
   dd if=/dev/zero of=/dev/sr0 bs=2048 count=1024
   mkudffs /dev/sr0

If 1024 blocks of 0s is not enough, then try to flood the whole medium
   dd if=/dev/zero of=/dev/sr0 bs=2048 count=11826176
Already tried that. dd complains:
  dd: opening `/dev/sr0': Read-only file system

Any ideas anyone?
You could use sequential burn programs like growisofs or xorriso.
Both can add files to ISO 9660 filesystems on BD-RE.
Those filesystems are mountable read-only.

If you canafford to have the medium only readable on Linux,
then you could try to format it by mkfs -t ext2.
But that might reduce the lifetime of your BD-RE by overwriting the
same blocks frequently.

Actually your mkudffs approach should just work (with all its
advantages and drawbacks towards ISO 9660 sessions.)

I use udf so I can access the files directly. I have found it useful to do a cmp between the files on the HD and the BD-RE to ensure they copied correctly. If the cmp fails, I rsync the bad file (these are .tar.lzma archives that are often quite large). I try this 3 times before reporting a backup error.

Reply to: