[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: growisofs 6.1 fails to allocate shared memory beyond 16m


> I'm trying to run growisofs 6.1 on Nslu2 device (with etch) it's small 
> device with low power consumption and with only 32M RAM:(
> I have tried to recompile debian source with smaller buffer size 
> WARN=-DDEFAULT_BUF_SIZE_MB=16 but i don't know how to check this buffer 
> size in complled executable.
> I have tried as root and as normal user and with ulimits too...
> Any help will be apreciated

I set the ring buffer size to 16 MB at run time by this option
  growisofs ...  -use-the-force-luke=bufsize:16M  ...
using a vanilla growisofs as it emerges from Andy's original
dvd+rw-tools-6.1 via command make.

dvd+rw-tools-6.1/growisofs.c  states that minimum size is 
1 MB and that only powers of 2 are permitted (i.e. 2M, 4M, ...).

For checking memory consumption of growisofs (on Linux) i would 
execute something like
  ps -eo pid,size,vsize,ucmd | fgrep growisofs
while growisofs is running. 

Have a nice day :)


Reply to: