[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: growisofs 6.1 fails to allocate shared memory beyond 16m

I'm trying to run growisofs 6.1 on Nslu2 device (with etch) it's small device with low power consumption and with only 32M RAM:(

According to instruction at http://www.nslu2-linux.org/wiki/OpenSlug/RecordCDROMandDVD - it is related to OpenSlug linux I have tried to recompile debian source with smaller buffer size WARN=-DDEFAULT_BUF_SIZE_MB=16 but i don't know how to check this buffer size in complled executable. Does dvd+rw-tools-6.1/debian/rules is good place to change DEFAULT_BUF_SIZE_MB?
        # Building package
-        $(MAKE) +btcflash
+        $(MAKE) +btcflash WARN=-DDEFAULT_BUF_SIZE_MB=8
        $(MAKE) rpl8
        sed -n "/^%changelog$$/,$$ p" dvd+rw-tools.spec > ChangeLog
(I have tried even 8M)
Anyway - when i run them i get in dmesg:
Out of Memory: Killed process 28666 (growisofs).
growisofs: page allocation failure. order:0, mode:0x200d2
I have tried as root and as normal user and with ulimits too...
Any help will be apreciated

regards Demsey

Reply to: