[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cdrecord: able to write successfully to CDRW, but not CDR media

VJ <codelad@gmail.com> wrote:

> Hello,
> I have a very strange problem while burning CDs after I upgraded from
> kernel 2.6.8 to 2.6.12 on debian testing. I am able to burn data on my
> CDRW media, but not to any CDR media. I have tried CDR media from
> different sets (purchased at different times), as well as 2 totally
> different brands.
> Actually, I am able to burn successfully to my CDRs - cdrecord runs
> without any error and completes the burning process. But I am unable
> to mount the CDRs successfully. I have tried multiple times with my
> CDRW media, and everything works fine, though.
> I get the following error when I try to mount CDRs burnt with cdrecord:
> % dmesg
> hdc: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
> hdc: media error (bad sector): error=0x34 { AbortedCommand
> LastFailedSense=0x03 }
> ide: failed opcode was: unknown
> end_request: I/O error, dev hdc, sector 64
> isofs_fill_super: bread failed, dev=hdc, iso_blknum=16, block=16
> % mount
> mount: wrong fs type, bad option, bad superblock on /dev/hdc,
>        missing codepage or other error
>        In some cases useful info is found in syslog - try
>        dmesg | tail  or so
> Below are verbose output from cdrecord. Like I mentioned, they don't
> give errors.
> With CDRW media (able to successfully mount it):
> ----------------------------------------------------------------------
> vj@quadros:~/.mldonkey/incoming/directories/BT$ cdrecord dev=/dev/hdc
> -v speed=8 debian-31r0a-i386-binary-2.iso
> cdrecord: No write mode specified.
> cdrecord: Asuming -tao mode.
> cdrecord: Future versions of cdrecord may have different drive
> dependent defaults.
> cdrecord: Continuing in 5 seconds...
> Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004
> Joerg Schilling
> NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
>       and thus may have bugs that are not present in the original version.
>       Please send bug reports and support requests to
> <cdrtools@packages.debian.org>.
>       The original author should not be bothered with problems of this version.

1)	You are not using cdrecord but a bastardized version created by Debian.

2)	All Linux kernels that are younger then 2.6.8 are broken and created
	an incompatible SCSI pass through interface with no reason. This 
	interface filters random SCSI commands....


If you have problems, always first check with a _recent_ official version.

Cdrtools-2.01.01a03 introduced a workaround for the Linux kernel defects in
case you are root or the cdrecord binary has been installed suid root.


 EMail:joerg@schily.isdn.cs.tu-berlin.de (home) Jörg Schilling D-13353 Berlin
       js@cs.tu-berlin.de		(uni)  
       schilling@fokus.fraunhofer.de	(work) Blog: http://schily.blogspot.com/
 URL:  http://cdrecord.berlios.de/old/private/ ftp://ftp.berlios.de/pub/schily

Reply to: