[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Write problems with unbranded DVD[+-]RW drive...

MacArthur, Ian (UK) wrote:

Greetings all,

At the weekend I got an unbranded DVD writer - I was in a local electronics shop, it was on offer very cheap. I have *a lot* of data to archive, and it seems like a bargain...
Claims to support + and - RW writing. (The retail box is marked PIKA ONE, but the drive itself is unbranded.)

Installed the latest cdrtools from source. It's what I know, so it seemed sensible to stick with it, it's always worked well before...
Installed in place of my CD burner, burned some test CD's with cdrecord, all worked fine.
Installed Ogle and checked I could watch DVD's smoothly - worked fine.
Installed cdrecord-ProDVD test binary.

A test run -dummy went smoothly, but the actual burn failed (see sample failure below).
This is with Verbatim 4x DVD-R media, in case that matters.
Fiddled about with hdparm in case my DMA settings were a problem, no better.

I hope that means that you saw that DMA was on. You want DMA, and if the DMA doesn't come on by itself, it sometimes means it will have problems (my DVD-104 needed an update to 1.40 firmware before the DMA defaulted on at boot time).

Tests with dvdrecord fail in exactly the same fashion (and again the dummy run is good.)

(coaster count now at 4 and rising...)

However, tests with dvd+rw-tools (my 3rd scheme...!) have all worked perfectly, both with DVD-R and DVD+RW media, so I guess that basic drive is OK.

While I have one + drive, I haven't tried + media in it, I find no advantage in price or speed, and a backup is a backup, the DVD-R read okay on more DVD-ROM drives I have, so that was the end of my interest.

At least, I can read the disks it's written back on my Mac, so I guess that's OK!

Is it likely something in my setup that's upsetting the cdrecord derived tools? How do I pin this down and fix it?

Base system is linux, with a 2.4.16 kernel, latest cdrtools tarball... what else do we need to know?

TIA for input.

cdrecord-ProDVD output follows...

root@immpc3 G # cdrecord-ProDVD dev=0,0,0 -speed=1 -nofix -v optISO.iso
Cdrecord-ProDVD-Clone 2.01a12 (i586-pc-linux-gnu) Copyright (C) 1995-2003 Jörg Schilling
Unlocked features: ProDVD Clone
Limited  features:
This copy of cdrecord is licensed for: private/research/educational_non-commercial_use
TOC Type: 1 = CD-ROM
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.20
Using libscg version 'schily-0.7'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'DVDRW   '
Identifikation : 'IDE1004         '
Revision       : '0040'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: DVD-R sequential recording
Profile: DVD+R
Profile: DVD+RW
Profile: DVD-RW sequential overwrite
Profile: DVD-RW restricted overwrite
Profile: DVD-R sequential recording (current)
Profile: DVD-ROM
Profile: CD-RW
Profile: CD-R
Profile: CD-ROM
Using generic SCSI-3/mmc-2 DVD-R/DVD-RW driver (mmc_dvd).
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1376256 = 1344 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data   541 MB
Total size:      541 MB = 277424 sectors
Current Secsize: 2048
Blocks total: 2298496 Blocks current: 2298496 Blocks remaining: 2021072
Starting to write CD/DVD at speed 1 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Starting new track at sector: 0
Track 01:    0 of  541 MB written./home/ian/src/cdrecord-prodvd-2.01a12-i586-pc: Input/outp
ut error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 01 F0 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 71 00 03 00 00 00 00 0A 00 00 00 00 0C 00 00 00
Sense Key: 0x3 Medium Error, deferred error, Segment 0
Sense Code: 0x0C Qual 0x00 (write error) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 50.404s timeout 100s

write track data: error after 1015808 bytes
/home/ian/src/cdrecord-prodvd-2.01a12-i586-pc: A write error occured.
/home/ian/src/cdrecord-prodvd-2.01a12-i586-pc: Please properly read the error message above
Writing  time:  103.440s
Average write speed   4.0x.
/home/ian/src/cdrecord-prodvd-2.01a12-i586-pc: fifo had 80 puts and 17 gets.
/home/ian/src/cdrecord-prodvd-2.01a12-i586-pc: fifo was 0 times empty and 1 times full, min
fill was 93%.
root@immpc3 G # eject /cdrecorder/

The write speed is interesting, although what it means on a fail is not obvious.

E. Robert Bogusta
 It seemed like a good idea at the time

Reply to: