[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compile against 2.6-test5



I posted a question at kerneltrap (and about 12 other places) while looking for a solution, sorry but i'm a pretty lame C coder, as is obvious by my not finding the rather simple solution pointed out by the other forum member. It worked like a charm for me. in the future, could the scsi features be disabled at compile? i was really only looking for ATAPI burning anyway, that was the whole point of using 2.6 :-).

I know feature requests from "lusers" who cant submit patches are looked down upon pretty heavily, but hey cant help trying.


>>>>>Fix form the forum member tonyicemanz as follows:

used cdrtools-2.01a19...

edit cdrtools-2.01/libscg/scsi-linux-sg.c

go to line 60 and you should see somewhere down that, something which look like this code... check this "patch", and put it in the code as I show ... and you will be able to compile it... (new part is in bold)


#ifndef LINUX_VERSION_CODE /* Very old kernel? */

#if LINUX_VERSION_CODE >= 0x01031a /* <linux/scsi.h> introduced in 1.3.26 */
#if LINUX_VERSION_CODE >= 0x020000 /* <scsi/scsi.h> introduced somewhere. */
/* Need to fine tune the ifdef so we get the transition point right. */
/******** New code to include the u8 type... */
#define __KERNEL__
#include <asm/types.h>
#undef __KERNEL__
/* End of new code ***************************/*

#include <scsi/scsi.h>
Rob Bogus wrote:

Joerg Schilling wrote:

Old-Return-Path: <mixonic@synitech.com>

I cant seem to compile cdrecord against 2.60-test5! is this a known issue? (in the code below i'm in the libscg dir, that seems to be the root of all the other errors, such as -lscg not found).

gcc-3.2.3.tar.gz - when this didnt work i tries smake since it was so strongly reccomended by the docs.....


ps, i dont think i'm actually on this list, so please CC....the webpage isnt very helpful in contacting the list......

[root@BettyBoop libscg]# smake
      ==> MAKING "all" ON SUBCOMPONENT ".../libscg.mk"
      ==> COMPILING "scsihack.o"
In file included from scsi-linux-sg.c:69,
               from scsihack.c:127:
/usr/src/linux/include/scsi/scsi.h:215: syntax error before "u8"
/usr/src/linux/include/scsi/scsi.h:215: warning: no semicolon at end of struct or union

Definitely a Linux kernel bug.

I did report this bug about a year ago, but Linus Torvalds prevents that this bug gets fixed :-(

??? this is a compiler warning message, how does that translate into a kernel bug? If it's a problem with gcc, it's still not a kernel bug.

Care to clarify this, or is that your standard answer to all problems of any kind on Linux?

E. Robert Bogusta
 It seemed like a good idea at the time

Reply to: