[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PROPOSAL: API for device locking library.

On Fri, 22 Oct 1999, Fabrizio Polacco wrote:

>         pid_t   islock_dev      ( const char * devname);
>         pid_t   lock_dev        ( const char * devname);
>         pid_t   relock_dev      ( const char * devname, pid_t old_pid);
>         pid_t   unlock_dev      ( const char * devname, pid_t pid);

This is obviously a nit, but I'd like to see these renamed to have the
dev at the beginning; nearly all system APIs use a prefix to keep the
namespace clean rather then a suffix (i.e. sig*, gtk*, Xt*, FD*), and it 
would be nice to be consistent.


|       "For the next two hours, VH1 will be filled with foul-mouthed,        |
|          crossdressing Australians. Viewer discretion is advised."          |
|                                                                             |
|  Linux Application Development  --  http://people.redhat.com/~johnsonm/lad  |

Reply to: