[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: init scripts and Required-Start

And there are a few bugs we've filed in the area that haven't been




On Sun, Jan 27, 2002 at 10:59:56AM +0100, Thorsten Kukuk wrote:
> Hi,
> I found a problem with our init script design. We have the flag
> "Required-Start" and all listed services must be started before the
> init script is allowed to be started. I undestand it in this way, 
> that an error should be printed if not all required services are
> installed ?
> My problem: for ypbind, I have 2 dependencies:
> 1. portmap, it is a hard requirement and it must be running before
>    ypbind could be started
> 2. ypserv: If ypserv is installed and configured, ypbind must be
>    started after it. If it is not installed or confiured (on a NIS
>    client, for example), we can ignore it.
> How should I write this dependencies in our current init script
> header? I think the only solution would be a second Start (and
> Stop ?) field, one for hard requirements, one for soft.
> Comments?
>   Thorsten
> -- 
> Thorsten Kukuk       http://www.suse.de/~kukuk/        kukuk@suse.de
> SuSE GmbH            Deutschherrenstr. 15-19       D-90429 Nuernberg
> --------------------------------------------------------------------    
> Key fingerprint = A368 676B 5E1B 3E46 CFCE  2D97 F8FD 4E23 56C6 FB4B
> -- 
> To UNSUBSCRIBE, email to lsb-discuss-request@lists.linuxbase.org
> with subject of "unsubscribe". Trouble? Email listmaster@lists.linuxbase.org

Reply to: