[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#639290: partial upgrade from squeeze to wheezy fails

On 08/26/2011 12:43 AM, Jonathan Nieder wrote:
> reassign 639290 apt
> quit
> Hi again,
> Adam Heath wrote:
>> 639290 says that you can deconfigure perl.  That is not possible.
> Why?  I thought the whole point of having a separate perl and
> perl-base is that perl is not essential.
> So as an intermediate state during an upgrade, it should be perfectly
> fine to deconfigure perl or to upgrade it without immediately
> configuring it.

How would you change the status in dpkg from Installed to
Half-Installed(ie, deconfigure it)?  I don't believe there is a way to
do that, except by way of unpacking some version(any version).

> Reassigning to APT.  Please feel free to reassign back to libc6 or
> perl when the problem is clearer.

Reply to: