[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#81829: "Segmentation faulty tree" (#270147) still present in Lenny, broken /var/cache/apt/*.bin available for download

tags 81829 - moreinfo

Axel Beckert wrote:

> I occasionally ran into this bug on Lenny, can't remember on which
> platform, but never deterministically.
> But today I reproducibly ran into this bug with both, apt-get and
> aptitude. Independent of what I did: aptitude; aptitude -u; aptitude
> upgrade; apt-get upgrade, I always get the "Segmentation faulty
> tree... 50%" ("Building dependency tree... 50%^MSegmentation fault").
> Moving /var/lib/apt/extended_states away didn't help.
> Couldn't even do an apt-get install gdb for generating a backtrace.
> Moving away pkgcache.bin and srcpkgcache.bin from /var/cache/apt/
> finally did help (thanks to waldi for that hint), but copying them
> back after upgrading two packages didn't reproduce the segfault --
> they always got recreated.

Thanks!  No promises about being able to take a look soon, but I've
downloaded them.

> They are available for download at
>   http://noone.org/debian/Bug-Reports/

Reply to: