[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#202493: apt-cache show <virtual package> prints nothing and exits successfully

Version: 0.7.26~exp12

Since this version the output for the command presented in the first message:

$ apt-cache show awk
N: Can't select versions from package 'awk' as it purely virtual
N: No packages found

So the initial request is satisfied (half way).

Note that the returncode is zero (success) as all sorts of tools (e.g. sbuild)
blow up if APT would fail in this case (we tried in earlier ~exp versions).

Showing a list of packages providing this virtual package might be
user-friendly in some way, but it is not expected by any tool and
a user will not expect it, too, as apt-cache is a lowlevel tool which
should do what it was told to do and not guess what the user might
have tried to say - and show should print the package record of the
requested package(s), not a list of packages you might want to feed
back to apt-cache show to see their package records.

Imagine a package which is real and also provided by some packages.
Should show now print a list of packages, show the record or both?

Best regards

David Kalnischkies

Reply to: