[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#596097: marked as done (apt: Please support setting a pin of 100 from within an archive (NotAutomaticButUpdates))

Your message dated Fri, 17 Sep 2010 22:17:12 +0000
with message-id <E1OwjF2-0008Ll-Vk@franck.debian.org>
and subject line Bug#596097: fixed in apt 0.8.5
has caused the Debian Bug report #596097,
regarding apt: Please support setting a pin of 100 from within an archive (NotAutomaticButUpdates)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

596097: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=596097
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: apt
Version: 0.8.3
Severity: wishlist


for backports.debian.org we use the NotAutomatic Flag to prevent users
from installing every backport. Unfortunatly that has the drawback of
preventing updates from installed backports. Even if our docs trys to
force users of pinning backports to 100 several don't read the docs or
don't understand it. 

It would be great if apt would support a Flag like:
NotAutomaticButUpdates or so which pins a remote repo to 100. If
needed I can provide a patch but my C++ isn't so fluid, so I would
prefer if I don't have to :). 

For backward compability it would be nice NotAutomatic and
NotAutomaticButUpdates would both work. 

Also it would be great if we could get the change into Squeeze :). 

Thanks in advance 


P.S. feel free to coordinate with the aptitude the maintainers,
reassagin the bug or whatever you think is useful. 

--- End Message ---
--- Begin Message ---
Source: apt
Source-Version: 0.8.5

We believe that the bug you reported is fixed in the latest version of
apt, which is due to be installed in the Debian FTP archive:

  to main/a/apt/apt-doc_0.8.5_all.deb
  to main/a/apt/apt-transport-https_0.8.5_i386.deb
  to main/a/apt/apt-utils_0.8.5_i386.deb
  to main/a/apt/apt_0.8.5.dsc
  to main/a/apt/apt_0.8.5.tar.gz
  to main/a/apt/apt_0.8.5_i386.deb
  to main/a/apt/libapt-pkg-dev_0.8.5_i386.deb
  to main/a/apt/libapt-pkg-doc_0.8.5_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 596097@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Michael Vogt <mvo@debian.org> (supplier of updated apt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 17 Sep 2010 22:05:06 +0200
Source: apt
Binary: apt apt-doc libapt-pkg-dev libapt-pkg-doc apt-utils apt-transport-https
Architecture: source all i386
Version: 0.8.5
Distribution: unstable
Urgency: low
Maintainer: APT Development Team <deity@lists.debian.org>
Changed-By: Michael Vogt <mvo@debian.org>
 apt        - Advanced front-end for dpkg
 apt-doc    - Documentation for APT
 apt-transport-https - APT https transport
 apt-utils  - APT utility programs
 libapt-pkg-dev - Development files for APT's libapt-pkg and libapt-inst
 libapt-pkg-doc - Documentation for APT development
Closes: 596097 596421 597145 597163
 apt (0.8.5) unstable; urgency=low
   [ Manpages translations ]
   * German (Chris Leick). Closes: #597163
   [ Michael Vogt ]
   * merged lp:~mvo/apt/conflicts-on-virtuals to better deal with
     conflicts/breaks against virtual packages (LP: #614993)
   [ David Kalnischkies ]
   * apt-pkg/policy.cc:
     - support 100-pinning in Release file with ButAutomaticUpgrades
       as requested by the backports crew (Closes: #596097)
   * apt-pkg/deb/deblistparser.cc:
     - overrule NotAutomatic in case of ButAutomaticUpgrades
   * debian/apt.cron.daily:
     - handle absolut directory paths correctly by loading directories
       directly instead of building the paths on our own (Closes: #596421)
   * debian/control:
     - build-depend on docbook-xml to ensure that the xml DTDs are always
       available on the buildds (Closes: #597145)
   * buildlib/debiandoc.mak, buildlib/po4a_manpage.mak:
     - ensure that the build fails if documentation building fails
   * doc/po/fr.po:
     - correct two syntax issues to ensure we can build fine
 7b82256a9fff93dc2090aa86e800bd2789618cda 1295 apt_0.8.5.dsc
 35d3033b0122343b542bb8e3ad2c38d89a679810 3134800 apt_0.8.5.tar.gz
 ffa0a97bc62ead8e6300ca6d79d39fb26c1f69dc 231710 apt-doc_0.8.5_all.deb
 204016c9cdeb2df92a9a85ca8d144faeb1947440 688394 libapt-pkg-doc_0.8.5_all.deb
 f7878daf381415a50f0446b71ab5d379e644b1d0 2131180 apt_0.8.5_i386.deb
 10316764f77a288343c3547061d0739fbbaa9805 149212 libapt-pkg-dev_0.8.5_i386.deb
 e1e054e4338e05f3813529307c145787c70b9d16 268544 apt-utils_0.8.5_i386.deb
 1ee5ace3fb4ca091029b17f36cb8483bfc294c60 81112 apt-transport-https_0.8.5_i386.deb
 a36750e8da1da18b1fe3890c4eb05a97ee499e274140537bc387cd2d52a5a521 1295 apt_0.8.5.dsc
 2811c9186dbdb1c9a004c2057dc2784532c1045f191f609e70234141a3e388dd 3134800 apt_0.8.5.tar.gz
 825ed4bd85b207d9f112c500e9eaa59383c92c5eef17d0228f3ebb850c1e90a8 231710 apt-doc_0.8.5_all.deb
 420839dae5acb5fd32a66f11e2a53f7aa712f1f32465e061d774f103ae6c4801 688394 libapt-pkg-doc_0.8.5_all.deb
 49cbddea1cd81fa01557f2bfd2e0456e6453b0ae230e064ee15e0b10bf14da46 2131180 apt_0.8.5_i386.deb
 3b9700b1e69bd650e64da7d31bc7efc21b7e46f1d3339654591d5d22d1a54fa9 149212 libapt-pkg-dev_0.8.5_i386.deb
 be11a72a1122e586ec29a1ab0901a264c8c3a1f0dc1604f0813559ebdb7eb16c 268544 apt-utils_0.8.5_i386.deb
 00fcc0e0a450da798376a1b4b2bd4f617d80b93bea83fdfbf205d248bdfe5cd6 81112 apt-transport-https_0.8.5_i386.deb
 19694c6a8f22514d5f631d162c6f5f67 1295 admin important apt_0.8.5.dsc
 22e4b08161cc0093c0979c1d8cec1de4 3134800 admin important apt_0.8.5.tar.gz
 9774031d08327433f1be36876be3fbca 231710 doc optional apt-doc_0.8.5_all.deb
 520bdcb18d8046f3383ccde871fbf33e 688394 doc optional libapt-pkg-doc_0.8.5_all.deb
 8e943fec2ec3c0547c72b90ccb02b2b0 2131180 admin important apt_0.8.5_i386.deb
 042737f2cae18925b1b78416e7d3d0eb 149212 libdevel optional libapt-pkg-dev_0.8.5_i386.deb
 46c3d82291d15a6ce78b824a0edca866 268544 admin important apt-utils_0.8.5_i386.deb
 12708952c15ca00b06649171b9fe39a4 81112 admin optional apt-transport-https_0.8.5_i386.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: