[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#551440: marked as done (showauto incorrectly described in apt-mark(8)?)

Your message dated Tue, 15 Dec 2009 11:02:20 +0000
with message-id <E1NKVAa-0008Jj-8m@ries.debian.org>
and subject line Bug#551440: fixed in apt 0.7.25
has caused the Debian Bug report #551440,
regarding showauto incorrectly described in apt-mark(8)?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

551440: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551440
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: apt
Severity: minor

apt-mark(8) says that showauto is used to print a list of *manually*
installed packages.  If this is true, it's confusing, because then the
command should be called showmanual, not showauto.

But looking at the output of showauto on my host, it appears that this
does indeed print the list of automatically installed packages.  So
the word "manually" should be replaced by "automatically" in


-- Package-specific info:

-- (/etc/apt/preferences present, but not submitted) --

-- (no /etc/apt/sources.list present) --

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (400, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26 (SMP w/3 CPU cores; PREEMPT)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=UTF-8) (ignored: LC_ALL set to en_US)
Shell: /bin/sh linked to /bin/bash

Versions of packages apt depends on:
ii  debian-archive-keyring        2009.01.31 GnuPG archive keys of the Debian a
ii  libc6                         2.9-25     GNU C Library: Shared libraries
ii  libgcc1                       1:4.4.1-4  GCC support library
ii  libstdc++6                    4.4.1-4    The GNU Standard C++ Library v3

apt recommends no packages.

Versions of packages apt suggests:
pn  apt-doc                       <none>     (no description available)
ii  bzip2                         1.0.5-3    high-quality block-sorting file co
ii  dpkg-dev               Debian package development tools
ii  lzma                          4.43-14    Compression method of 7z format in
ii  python-apt             Python interface to libapt-pkg
ii  synaptic                      0.62.9     Graphical package manager

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: apt
Source-Version: 0.7.25

We believe that the bug you reported is fixed in the latest version of
apt, which is due to be installed in the Debian FTP archive:

  to main/a/apt/apt-doc_0.7.25_all.deb
  to main/a/apt/apt-transport-https_0.7.25_i386.deb
  to main/a/apt/apt-utils_0.7.25_i386.deb
  to main/a/apt/apt_0.7.25.dsc
  to main/a/apt/apt_0.7.25.tar.gz
  to main/a/apt/apt_0.7.25_i386.deb
  to main/a/apt/libapt-pkg-dev_0.7.25_i386.deb
  to main/a/apt/libapt-pkg-doc_0.7.25_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 551440@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Michael Vogt <mvo@debian.org> (supplier of updated apt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Tue, 15 Dec 2009 09:21:55 +0100
Source: apt
Binary: apt apt-doc libapt-pkg-dev libapt-pkg-doc apt-utils apt-transport-https
Architecture: source all i386
Version: 0.7.25
Distribution: sid
Urgency: low
Maintainer: APT Development Team <deity@lists.debian.org>
Changed-By: Michael Vogt <mvo@debian.org>
 apt        - Advanced front-end for dpkg
 apt-doc    - Documentation for APT
 apt-transport-https - APT https transport
 apt-utils  - APT utility programs
 libapt-pkg-dev - Development files for APT's libapt-pkg and libapt-inst
 libapt-pkg-doc - Documentation for APT development
Closes: 245250 249383 273100 355782 377424 448249 459344 463354 479997 497983 505020 518473 521284 521289 522238 534992 548571 550952 551440 551534 552535 552606 554898 555797 557085 557674 558737 558757 558803 559277 561109
 apt (0.7.25) sid; urgency=low
   [ Christian Perrier ]
   * Fix apt-ftparchive(1) wrt description of the "-o" option.
     Thanks to Dann Frazier for the patch. Closes: #273100
   * po/LINGUAS. Re-disable Hebrew. Closes: #534992
   * po/LINGUAS. Enable Asturian and Lithuanian
   * Fix typo in apt-cache.8.xml: nessasarily
   * Fix "with with" in apt-get.8.xml
   * Fix some of the typos mentioned by the german team
     Closes: #479997
   * Polish translation update by Wiktor Wandachowicz
     Closes: #548571
   * German translation update by Holger Wansing
     Closes: #551534
   * Italian translation update by Milo Casagrande
     Closes: #555797
   * Simplified Chinese translation update by Aron Xu
     Closes: #558737
   * Slovak translation update by Ivan Masár
     Closes: #559277
   [ Michael Vogt ]
   * apt-pkg/packagemanager.cc:
     - add output about pre-depends configuring when debug::pkgPackageManager
       is used
   * methods/https.cc:
     - fix incorrect use of CURLOPT_TIMEOUT, closes: #497983, LP: #354972
       thanks to Brian Thomason for the patch
   * merge lp:~mvo/apt/netrc branch, this adds support for a
     /etc/apt/auth.conf that can be used to store username/passwords
     in a "netrc" style file (with the extension that it supports "/"
     in a machine definition). Based on the maemo git branch (Closes: #518473)
     (thanks also to Jussi Hakala and Julian Andres Klode)
   * apt-pkg/deb/dpkgpm.cc:
     - add "purge" to list of known actions
   * apt-pkg/init.h:
     - add compatibility with old ABI name until the next ABI break
   * merge segfault fix from Mario Sanchez Prada, many thanks
     (closes: #561109)
   [ Brian Murray ]
   * apt-pkg/depcache.cc, apt-pkg/indexcopy.cc:
     - typo fix (LP: #462328)
   [ Loïc Minier ]
   * cmdline/apt-key:
     - Emit a warning if removed keys keyring is missing and skip associated
       checks (LP: #218971)
   [ David Kalnischkies ]
   * apt-pkg/packagemanager.cc:
     - better debug output for ImmediateAdd with depth and why
     - improve the message shown for failing immediate configuration
   * doc/guide.it.sgml: moved to doc/it/guide.it.sgml
   * doc/po4a.conf: activate translation of guide.sgml and offline.sgml
   * doc/apt.conf.5.xml:
     - provide a few more details about APT::Immediate-Configure
     - briefly document the behaviour of the new https options
   * doc/sources.list.5.xml:
     - add note about additional apt-transport-methods
   * doc/apt-mark.8.xml:
     - correct showauto synopsis, thanks Andrew Schulman (Closes: #551440)
   * cmdline/apt-get.cc:
     - source should display his final pkg pick (Closes: #249383, #550952)
     - source doesn't need the complete version for match (Closes: #245250)
     - source ignores versions/releases if not available (Closes: #377424)
     - only warn if (free) space overflows (Closes: #522238)
     - add --debian-only as alias for --diff-only
   * methods/connect.cc:
     - display also strerror of "wicked" getaddrinfo errors
     - add AI_ADDRCONFIG to ai_flags as suggested by Aurelien Jarno
       in response to Bernhard R. Link, thanks! (Closes: #505020)
   * buildlib/configure.mak, buildlib/config.{sub,guess}:
     - remove (outdated) config.{sub,guess} and use the ones provided
       by the new added build-dependency autotools-dev instead
   * configure.in, buildlib/{xml,yodl,sgml}_manpage.mak:
     - remove the now obsolete manpage buildsystems
   * doc/{pl,pt_BR,es,it}/*.{sgml,xml}:
     - convert all remaining translation to the po4a system
   * debian/control:
     - drop build-dependency on docbook-utils and xmlto
     - add build-dependency on autotools-dev
     - bump policy to 3.8.3 as we have no outdated manpages anymore
   * debian/NEWS:
     - fix a typo in 0.7.24: Allready -> Already (Closes: #557674)
   * ftparchive/writer.{cc,h}:
     - add APT::FTPArchive::LongDescription to be able to disable them
   * apt-pkg/deb/debsrcrecords.cc:
     - use "diff" filetype for .debian.tar.* files (Closes: #554898)
   * methods/rred.cc:
     - rewrite to be able to handle even big patch files
     - adopt optional mmap+iovec patch from Morten Hustveit
       (Closes: #463354) which should speed up a bit. Thanks!
   * methods/http{,s}.cc
     - add config setting for User-Agent to the Acquire group,
       thanks Timothy J. Miller! (Closes: #355782)
     - add https options which default to http ones (Closes: #557085)
   * debian/apt.cron.daily:
     - check cache size even if we do nothing else otherwise, thanks
       Francesco Poli for patch(s) and patience! (Closes: #459344)
   * ftparchive/*:
     - fix a few typos in strings, comments and manpage,
       thanks Karl Goetz! (Closes: #558757)
   [ Carl Chenet ]
   * cmdline/apt-mark:
     - print an error if a new state file can't be created
       (Closes: #521289) and
     - exit nicely if python-apt is not installed (Closes: #521284)
   [ Chris Leick ]
   * doc/de: German translation of manpages (Closes: #552606)
   * doc/ various manpages:
     - correct various errors, typos and oddities (Closes: #552535)
   * doc/apt-secure.8.xml:
     - replace literal with emphasis tags in Archive configuration
   * doc/apt-ftparchive.1.xml:
     - remove informalexample tag which hides the programlisting
   * doc/apt-get.8.xml:
     - change equivalent "for" to "to the" (purge command)
     - clarify --fix-broken sentence about specifying packages
   [ Eugene V. Lyubimkin ]
   * apt-pkg/contib/strutl.h
     - Avoid extra inner copy in APT_MKSTRCMP and APT_MKSTRCMP2.
   * build infrastructure:
     - Bumped libapt version, excluded eglibc from SONAME. (Closes: #448249)
   [ Julian Andres Klode ]
   * doc/apt.conf.5.xml:
     - Deprecate unquoted values, string concatenation and explain what should
       not be written inside a value (quotes,backslash).
     - Restrict option names to alphanumerical characters and "/-:._+".
     - Deprecate #include, we have apt.conf.d nowadays which should be
   * ftparchive/apt-ftparchive.cc:
     - Call setlocale() so translations are actually used.
   * debian/apt.conf.autoremove:
     - Add kfreebsd-image-* to the list (Closes: #558803)
 0551877aeda418d2b9feb058502bdd2115e3b7e9 1204 apt_0.7.25.dsc
 3b0993993a2cb4aab00e0fbbdea48bb0d8fa8473 2583260 apt_0.7.25.tar.gz
 fc70fd1e9882b8cb141b10312f4dc04e82f69dc0 80550 apt-doc_0.7.25_all.deb
 269e755eaca9dee5ac9a76b58d87188a60da7c56 132068 libapt-pkg-doc_0.7.25_all.deb
 da50b0673fc2ac4db2fdf959b80990f9ff9f8c15 1716802 apt_0.7.25_i386.deb
 314644810d0d311d06497e45273a46a946701f6f 120152 libapt-pkg-dev_0.7.25_i386.deb
 303b988d9aac8e099eb30d4e8219ce4c30751a8c 221976 apt-utils_0.7.25_i386.deb
 0beeb0427f01b4d8c0e0ce0811da83db55a9034b 67736 apt-transport-https_0.7.25_i386.deb
 46a60222c55e5ea2cc0a9b93bd4ca24becfdc5e21ec1bb70e671a3b194b9a6e9 1204 apt_0.7.25.dsc
 8463bd51a1ed3c21458d2173a08e652ec9c9da413daa07d9bfb47880ba262286 2583260 apt_0.7.25.tar.gz
 ddcbddc0651158125c21424dd0464751807b22a16d160f2db7762eae9b0b412f 80550 apt-doc_0.7.25_all.deb
 3023f71fa7f4d953353962960ca3ad3628eed0630f55de3ab31433a33ef1c391 132068 libapt-pkg-doc_0.7.25_all.deb
 7ae23af827631f3b619d9e8bdd4ecda0ade5f63cebe8cbc91cad328024d56cb0 1716802 apt_0.7.25_i386.deb
 e137893bae65cbed9f114acd2dc1f6b20b5dcb1294710c10c8b02094e2fda99b 120152 libapt-pkg-dev_0.7.25_i386.deb
 7650a6f760cc8e1d2b9153a1cc414c7e051f8144a82643a20a02d33bac46a663 221976 apt-utils_0.7.25_i386.deb
 81dd030fcdc27402d717bb52930c317630b2fa9bf9cc81aa74a4a8e24261d528 67736 apt-transport-https_0.7.25_i386.deb
 4076ffc425018de148d3bf16960c45a3 1204 admin important apt_0.7.25.dsc
 959297b6c55cf143d947720c15ddcb0a 2583260 admin important apt_0.7.25.tar.gz
 27e16ca1810e8339f8b6ec671e7f49a0 80550 doc optional apt-doc_0.7.25_all.deb
 8dcca68bb4669d55ea3c8e5fff27eb6b 132068 doc optional libapt-pkg-doc_0.7.25_all.deb
 f7fb4189e3abb4d38ce968b51ff49e48 1716802 admin important apt_0.7.25_i386.deb
 ef8186444932a275dbc8d8a055370949 120152 libdevel optional libapt-pkg-dev_0.7.25_i386.deb
 f6aac1a42fc0023fc9975640fb81c504 221976 admin important apt-utils_0.7.25_i386.deb
 af991e4311ae063247ced9318865136b 67736 admin optional apt-transport-https_0.7.25_i386.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: