[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#521386: Upgrade from Lenny to Squeeze with problems

Package: apt
Severity: important

*** Please type your report below this line ***

I have 3 PC's with nearly identical hardware running Debian Testing.
Up to now the sources.list was pointing to "lenny".
After the migration of lenny to stable i altered this to "testing".
First everything looks O.K.

Then many packages where set on hold and then i had the problem that is described
in this bug:
Please refer to it.

On 2 PC's i manually reinstalled the holded packages with "apt-get install ..."
Then i did an "apt-get upgrade" again.
Everything looks fine afterwards, there where no packages on hold or to upgrade.
Also an "apt-get check" shows no result.

But there is on every PC this strange problem with bug 521271, and i don't rely
that everything is O.K.
I can work normally with the Debian, before and afterwards i reinstalled the holded
But obviously something is broken and i don't know which packages and applications
else are working not properly?

How can i check this?
Maybe i have done a mistake going from lenny to testing?

Here is the output from the "apt-get upgrade" with the packages on hold:

Die folgenden Pakete sind zurückgehalten worden:
  avahi-daemon chaplin ffmpeg ghostscript gksu gnome-keyring gnome-media
gnome-media-common grub iceweasel
  libaqbanking20-plugins-qt libavdevice52 libavformat52 libbonoboui2-0
libbonoboui2-common libboost-regex1.34.1
  libcurl3 libcurl3-gnutls libdvdnav4 libgail-common libgail18 libgksu2-0
libgnome-media0 libgnomeprintui2.2-0
  libgnomeprintui2.2-common libgnomeui-0 libgnomeui-common libgs8 libgtk2.0-0
libgtk2.0-bin libgtkmm-2.4-1c2a
  libkrb53 libmagick10 libnotify1 libpam-modules librsvg2-2 librsvg2-common
libsmbclient libwebkit-1.0-1 libwnck22
  libx11-6 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-xv0 libxcb1 lsdvd
notification-daemon ogmtools
  python-gnome2 xulrunner-1.9 yelp
Die folgenden Pakete werden aktualisiert:
  aqbanking-tools bash cpio cpp curl debconf debconf-i18n debhelper eject findutils
g++ gcc gcc-multilib
  geoip-database ghostscript-x gnome-doc-utils gnome-icon-theme gnupg gpgv grep
groff-base gs-common
  gstreamer0.10-alsa gstreamer0.10-lame gstreamer0.10-plugins-base gstreamer0.10-x
gzip hal-info imagemagick info
  iso-codes lib32asound2 lib32ncurses5 libaa1 libao2 libapr1 libaqbanking-data
libaqbanking-plugins-libgwenhywfar47 libaqbanking20 libaqbanking20-plugins
libaqhbci13 libaqofxconnect4
  libasound2 libavahi-client3 libavahi-common-data libavahi-common3 libavahi-glib1
libavahi-qt3-1 libbonobo2-0
  libbonobo2-common libboost-filesystem1.34.1 libboost-program-options1.34.1 libc6
libc6-dev libc6-dev-i386
  libc6-i386 libdevmapper1.02.1 libfinance-quote-perl libgeoip1 libgnome-keyring0
libgnome-menu2 libgnome2-0
  libgnome2-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra
  libgtk2.0-common libgtop2-7 libgtop2-common libhesiod0 libidl0 liblua5.1-0
libmagick++10 libmozjs1d libmpcdec3
  libmpfr1ldbl libncurses5 libncursesw5 libogg0 liborbit2 libpam-gnome-keyring
libpam-runtime libpam0g libpisock9
  libpng12-0 libpulse0 libpurple-bin libpurple0 libreadline5 libsamplerate0 libsane
libsane-extras libsensors4
  libsvn1 libtalloc1 libtheora0 libts-0.0-0 libvorbis0a libvorbisenc2
libvorbisfile3 libwbclient0 libwnck-common
  libwww-perl libx11-data libxapian15 libxml2 libxml2-utils libxrandr2 lm-sensors
locales man-db module-init-tools
  ncurses-base ncurses-bin pdfedit perlmagick pidgin pidgin-data pmount
python-libxml2 readline-common sane-utils
  subversion tcl8.4 tcl8.5 timidity tk8.4 tk8.5 vim-common vim-tiny vorbis-tools
132 aktualisiert, 0 neu installiert, 0 zu entfernen und 52 nicht aktualisiert. Es
müssen 84,9MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 1812kB Plattenplatz zusätzlich benutzt.


-- Package-specific info:

-- apt-config dump --

APT "";
APT::Architecture "amd64";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "1";
APT::Install-Suggests "0";
APT::Acquire "";
APT::Acquire::Translation "environment";
APT::CDROM::NoMount "true";
APT::Authentication "";
APT::Authentication::TrustCDROM "true";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^linux-image.*";
APT::NeverAutoRemove:: "^linux-restricted-modules.*";
APT::Periodic "";
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Update "";
APT::Update::Post-Invoke-Success "";
APT::Update::Post-Invoke-Success:::: "touch
/var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";
APT::Archives "";
APT::Archives::MaxAge "30";
APT::Archives::MinAge "2";
APT::Archives::MaxSize "500";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::userstatus "status.user";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::dpkg "/usr/bin/dpkg";
Dir::Log "var/log/apt";
Dir::Log::Terminal "term.log";
Acquire "";
Acquire::gpgv "";
Acquire::gpgv::Options "";
Acquire::gpgv::Options:: "--ignore-time-conflict";
Acquire::cdrom "";
Acquire::cdrom::mount "/cdrom";
Acquire::cdrom::/cdrom/ "";
Acquire::cdrom::/cdrom/::Mount "true";
Acquire::cdrom::/cdrom/::UMount "true";
Unattended-Upgrade "";
Unattended-Upgrade::Allowed-Origins "";
Unattended-Upgrade::Allowed-Origins:: "Debian stable";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
DPkg::Post-Invoke "";
DPkg::Post-Invoke:: "if [ -d /var/lib/update-notifier ]; then  touch
/var/lib/update-notifier/dpkg-run-stamp; fi";

-- (no /etc/apt/preferences present) --

-- /etc/apt/sources.list --

# deb cdrom:[Debian GNU/Linux LennyBeta2 _Lenny_ - Official Beta amd64 NETINST
Binary-1 20080608-11:10]/ lenny main

#deb cdrom:[Debian GNU/Linux LennyBeta2 _Lenny_ - Official Beta amd64 NETINST
Binary-1 20080608-11:10]/ lenny main

deb http://ftp.de.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.de.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

deb http://www.debian-multimedia.org testing main

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-1) (ignored: LC_ALL
set to de_DE)
Shell: /bin/sh linked to /bin/bash

Versions of packages apt depends on:
ii  debian-archive-keyring        2009.01.31 GnuPG archive keys of the Debian a
ii  libc6                         2.9-4      GNU C Library: Shared libraries
ii  libgcc1                       1:4.3.3-3  GCC support library
ii  libstdc++6                    4.3.3-3    The GNU Standard C++ Library v3

apt recommends no packages.

Versions of packages apt suggests:
pn  apt-doc                      <none>      (no description available)
ii  aptitude            terminal-based package manager
ii  bzip2                        1.0.5-1     high-quality block-sorting file co
ii  dpkg-dev                     1.14.25     Debian package development tools
ii  lzma                         4.43-14     Compression method of 7z format in
pn  python-apt                   <none>      (no description available)

-- no debconf information

Reply to: