[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#489825: apt-get dependency system is broken (started an upgrade, now fails because of unmet dependencies)

On Tue, Jul 08, 2008 at 03:43:10AM +0200, Vincent Lefevre <vincent@vinc17.org> was heard to say:


> dpkg: latex-ucs: dependency problems, but removing anyway as you request:
>  latex-ucs-contrib depends on latex-ucs.
> Removing latex-ucs ...
> /var/lib/dpkg/info/latex-ucs.postrm: line 12: mktexlsr: command not found
> dpkg: error processing latex-ucs (--purge):
>  subprocess post-removal script returned error exit status 127

  There's your problem.  latex-ucs can't be removed and so the dpkg command
will fail.  apt-file tells me that texlive-base-bin contains mktexlsr,
btw, so your next attempt to upgrade will probably fail until you
install that package by hand (using "dpkg -i").

  [snip the dpkg command failing]

> Then I tried again, but some dependencies are now unmet!

  Yes, because dpkg was interrupted partway through removing the
packages that depend on tetex.  You'll need to finish the installation
by hand or run an appropriate tool (such as "apt-get -f" or aptitude)
to resolve the dependencies.


> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>   latex2rtf: Depends: tetex-bin but it is not going to be installed or
>                       texlive-base but it is not going to be installed

  You need to install texlive-base.  I guess it probably got pulled in
before by, e.g., texlive-fonts-recommended:

>   texlive-fonts-recommended: Depends: texlive-base (>= 2007-11) but it is not going to be installed
>                              Recommends: texlive-fonts-recommended-doc but it is not going to be installed
>                              Recommends: tipa (>= 2:1.2-2.1) but it is not going to be installed

  which is now installed and won't trigger autoinstallation of

>   lmodern: Depends: tex-common (>= 1.10) but 1.9 is to be installed

  You need to install a newer version of tex-common.

>   texlive-latex-extra: Depends: preview-latex-style but it is not going to be installed

  You need to install preview-latex-style.

> $ sudo apt-get -f install

  I don't know offhand how "apt-get -f" works so I can't comment -- it
looks like it probably tried to resolve recommendations (e.g.,
texlive-base-bin recommends texlive-base-bin-doc).

  You could try passing the same command-line to aptitude and see if it
does anything better.  Anyway, if there is a bug I think it's in
latex-ucs (removal shouldn't fail!), so I'll reassign this over there.


Reply to: