[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#410695: zope2.7 causqe upgrade failure

Le samedi 03 mars 2007 à 20:33 -0800, Steve Langasek a écrit :
> On Fri, Mar 02, 2007 at 07:49:53PM +0100, Josselin Mouette wrote:
> > I have already encountered similar problems in the past, with GConf, and
> > they were triggered by a circular dependency.
> > It seems that APT is unable to deal with such dependencies correctly, as
> > it removes packages depending on each other in random order (which is
> > fair) but can also remove one of them before packages depending on the
> > other are removed.
> Sorry, can you point to the dependency loop at work here?  I didn't notice
> one in my examination.

Hm, I have a bit overlooked it. This isn't caused by a dependency loop
but I think the underlying issue is the same:
      * APT needs to remove python2.3 before installing python because
        the latter in etch has a conflict against the former;
      * it removes python2.3 before installing python;
      * python2.3 isn't available in zope2.7's prerm.

The underlying issue is that APT doesn't take into account dependencies
for the prerm of packages being removed when calculating the execution

> As the recommended upgrade path from sarge->etch is aptitude rather than
> apt, the main reason I've left this as 'serious' is concern that the cause
> is common to both apt-get and aptitude and just triggers sooner with apt-get
> (which seems to be the case if the problem is the dependency loop bug), and
> that, in the absence of clear understanding of the origin of the bug, there
> could be a significant number of other upgrade scenarios where apt would
> fail.
> But if this only affects circular dependencies, that seems unlikely.

In all cases it seems unlikely to affect aptitude. If it is capable to
handle dependencies for prerm's in the circular loop case, it is most
probably capable to do the same in simpler cases like this one.

> > An acceptable workaround would be to upload a dummy zope2.7 package,
> > which doesn't depend on python2.3, and would make the transition to
> > zope2.9. At least, such upgrades wouldn't fail.
> Based on discussions on the -python list, where users insist that it's
> unacceptable even for zope2.7's removal to be forced on upgrade to etch, it
> seems unlikely that this would be accepted either.

Are you suggesting to re-upload python2.3 and zope2.7 to etch?

: :' :      We are debian.org. Lower your prices, surrender your code.
`. `'       We will add your hardware and software distinctiveness to
  `-        our own. Resistance is futile.

Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=

Reply to: