[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#374560: Unable to parse package file /var/lib/dpkg/status

On Sat, Jun 24, 2006 at 11:53:22PM +0200 or thereabouts, Nicolas François wrote:
> reassign 374560 apt
> thanks
> Hello Sascha,
> According to your status file, you are using apt
> If I understand correctly, this bug is in apt, and was fixed by apt
> 0.6.44. Sascha, can you check?
> You can probably fix this problem by downloading the apt package from a
> debian server [0], and install it with dpkg -i <apt_...>.deb.
> You should be able to use aptitude again afterwards.
> apt maintainers:
>  * FYI, the status file (link in the original file) contains a package
>    whose data are more than 32k.
>  * BTW, you can probably also close #276060, which looks like the same issue
>    (fixed with #350025)
> [0] for example from:
>     ftp://debian.tu-bs.de/debian/pool/main/a/apt/apt_0.6.44.2_i386.deb

Hi Nekral,

I have done as you said:

fileserver:~# dpkg -i apt_0.6.44.2_i386.deb 
(Lese Datenbank ... 74067 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von apt (durch apt_0.6.44.2_i386.deb) ...
Entpacke Ersatz für apt ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von apt:
 apt hängt ab von libgcc1 (>= 1:4.1.0); aber:
  Version of libgcc1 on system is 1:4.0.3-1.
 apt hängt ab von libstdc++6 (>= 4.1.0); aber:
  Version of libstdc++6 on system is 4.0.3-1.
dpkg: Fehler beim Bearbeiten von apt (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:

fileserver:~# aptitude update
aptitude: error while loading shared libraries: libapt-pkg-libc6.3-6.so.3.10: cannot open shared object file: No such file or directory

so I decided to keep installing via dpkg the missing packages:


and as the shared lib error stayed afterwards, I copied
/usr/lib/libapt-pkg-libc6.3-6.so.3.10.0 from another host to

Now I am done, I thought. But aptitude update gave the same error as before.
Humpf, so I gave apt-get update a try - lucky. After this successful update I
tried aptitude update again: Also successful now.

Strange is that /var/lib/dpkg was not yet altered in any way.
I verified by dpkg -l that the package version state of the new packages was
not updated.

So now the package information system has the state before/while the apt error
with some new files in the system, which don't make trouble and will be 
overwritten in the near future when their package is updated, right? -
Do you agree that there is no need to deinstall the handmade

Seems to me as if the error was resolved. Not so easy but luckily.

Thank you for your help.
I am going to make an aptitude upgrade and when everything is alright, I
will close the bug and the other one, too.


Reply to: