[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#361234: apt: apt fails to parse huge line in unstable sources info

# Merge duplicate filed bugs
merge 361234 361237

On Friday, April 07, 2006 11:21 AM, Peter T. Breuer <ptb@lab.it.uc3m.es>

> Package: apt
> Version: 0.5.4
> Severity: important
> -- System Information
> Debian Release: 2.2
> Kernel Version: Linux betty.it.uc3m.es #11 PREEMPT Fri Mar
> 31 18:52:16 CEST 2006 i686 GNU/Linux
> Versions of the packages apt depends on:
> hi  libc6          2.1.3-25       GNU C Library: Shared libraries and
> Timezone data
> ii  libstdc++2.10  2.95.4-22      The GNU stdc++ library

Are those versions really correct? You're running apt from the now
"oldstable" woody distribution, together with a libc that's even older than
that, a fortnight old kernel and a Sources file for unstable?

> E: Unable to parse package file
> (1)
> E: Tried to dequeue a fetching object
> E: Tried to dequeue a fetching object
> E: Tried to dequeue a fetching object
> betty:/tmp%
> The culprit is the huge line about 89700 lines into the file:
>   Package: linux-2.6
>   Binary: linux-image-2.6-k7 .... (masses and masses) ....
>   Version: 2.6.16-5

With all due respect I'm not really surprised it doesn't work. Your apt
version is nearly five years old and although I can't see anything obvious
in the changelog it's entirely likely that whatever caused this issue was
fixed long ago. Is there any chance you could possibly test it with a more
up-to-date apt?



Reply to: