[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#263441: apt: internal error when using dselect-upgrade

severity 263441 normal

On Wed, Aug 04, 2004 at 03:03:24PM +0200, Sebastian Reichelt wrote:

> This is what I get when I select [I]nstall from dselect, or run:
> apt-get dselect-upgrade
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following packages have unmet dependencies:
>   eclipse-platform: Depends: j2re1.4 but it is not going to be installed or
>                              j2re1.3 but it is not installable or
>                              java2-runtime
> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by
> held packages.
> E: Internal Error, problem resolver broke stuff
> Neither j2re1.4 nor eclipse-platform were updated; they are and will stay
> installed. I don't have any held packages either.

This is most likely a problem with some of the non-Debian packages that you
have installed.  Try removing those and using alternatives in Debian, and
see if that works.

 - mdz

Reply to: