[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#167560: apt-get install: unmet dependencies with woody+updates+proposed for libssl-dev

Package: apt
Version: 0.5.4
Severity: normal

I have the following lines in sources.list:
deb ftp://ftp.debian.org/debian woody main contrib non-free
deb ftp://nonus.debian.org/debian-non-US woody/non-US main contrib non-free
deb http://security.debian.org woody/updates main contrib non-free
deb ftp://ftp.debian.org/debian woody-proposed-updates main contrib non-free

Running apt-get install libssl-dev gives:
libssl-dev: Depends: libssl0.9.6 (= 0.9.6c-2.woody.1) but 0.9.6g-0.woody.1
is to be installed

Cache has been cleared and updated prior to running apt-get install and
proxy is disabled. In case it matters, libc6 is from testing and has been
pulled in by installing gcc-3.2 previously.

Here is what apt-cache says:

apt-cache show libssl0.9.6 | grep Filename
Filename: pool/main/o/openssl/libssl0.9.6_0.9.6g-0.woody.1_i386.deb
Filename: pool/updates/main/o/openssl/libssl0.9.6_0.9.6c-2.woody.1_i386.deb
Filename: pool/main/o/openssl/libssl0.9.6_0.9.6c-2_i386.deb

apt-cache show libssl-dev | grep Filename
Filename: pool/main/o/openssl/libssl-dev_0.9.6g-0.woody.1_i386.deb
Filename: pool/updates/main/o/openssl/libssl-dev_0.9.6c-2.woody.1_i386.deb
Filename: pool/main/o/openssl/libssl-dev_0.9.6c-2_i386.deb

I solved (as suggested by Christoph Martin <martin@uni-mainz.de>
for Bug#167494) with the following:

apt-get install libssl-dev=0.9.6g-0.woody.1

but I thought apt should have dealt with it on its own.

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux nausicaa 2.4.19-nausicaa #1 Sat Oct 26 15:57:09 CEST 2002 i686
Locale: LANG=it_IT@euro, LC_CTYPE=en_IE@euro

Versions of packages apt depends on:
ii  libc6                  2.2.5-14.3        GNU C Library: Shared libraries an
ii  libstdc++2.10-glibc2.2 1:2.95.4-11woody1 The GNU stdc++ library

Reply to: