[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#114556: apt: apt seems to invent a conflict

Package: apt
Version: 0.5.3
Severity: important

This looks really weird:

thunder:~# apt-get -o Debug::pkgProblemResolver=yes install adduser
Reading Package Lists...
Building Dependency Tree...
Starting 2
Investigating sfs-common
Package sfs-common has broken dep on libgmp3
  Considering libgmp3 7 as a solution to sfs-common 1
    Reinst Failed because of libgmp3
  Removing sfs-common rather than change libgmp3
Investigating sfs-client
Package sfs-client has broken dep on sfs-common
  Considering sfs-common 1 as a solution to sfs-client 0
    Reinst Failed because of sfs-common
  Removing sfs-client rather than change sfs-common
Investigating telnetd-ssl
Package telnetd-ssl has broken dep on passwd
  Considering passwd 21 as a solution to telnetd-ssl -1
  Removing telnetd-ssl rather than change passwd
Investigating pidentd-des
Package pidentd-des has broken dep on libssl0.9.6
  Considering libssl0.9.6 34 as a solution to pidentd-des -1
  Removing pidentd-des rather than change libssl0.9.6

I don't see at all why any of these deps are broken. For example
look at sfs-common:

thunder:~# dpkg -s sfs-common | grep libgmp3
Depends: libc6 (>= 2.2.3-7), libgmp3, libstdc++2.10-glibc2.2, sfs-lib (>= 0.5i-8), nfs-common, adduser
thunder:~# dpkg -l libgmp3
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  libgmp3        3.1.1-9        Multiprecision arithmetic library

Similar for all the other errors.


-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux thunder 2.4.7-ac5+freeswan191 #3 Sat Aug 4 20:48:41 CEST 2001 i686
Locale: LANG=en_GB.ISO-8859-1, LC_CTYPE=en_GB.ISO-8859-1

Versions of packages apt depends on:
ii  libc6                  2.2.4-1           GNU C Library: Shared libraries an
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.010902 The GNU stdc++ library

Reply to: