[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#107380: apt is installing packages which are not depended upon

Package: apt
Version: 0.5.3
Severity: normal

I'm attempting to install xae but would only expect 
psgml and it dependancies to be installed.

akumria@kaelor:~$ sudo apt-get install xae
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  eieio psgml sgml-base sgml-data speedbar 
The following NEW packages will be installed:
  eieio psgml sgml-base sgml-data speedbar xae 
0 packages upgraded, 6 newly installed, 0 to remove and 7  not upgraded.
Need to get 1746kB/2472kB of archives. After unpacking 17.5MB will be used.
Do you want to continue? [Y/n] n

akumria@kaelor:~$ apt-cache show xae      
Package: xae
Version: 1.0beta6-2
Depends: xemacs21 | xemacs21-gtk | xemacs20 | emacsen, psgml | xemacs21, eieio | xemacs21
Suggests: java-virtual-machine

akumria@kaelor:~$ apt-cache show psgml
Package: psgml
Version: 1.2.2-5
Depends: emacs20 | emacs21, sgml-base, sgml-data, fileutils (>= 4.0)
Recommends: sp (>= 1.3)
Suggests: debiandoc-sgml, linuxdoc-sgml, make

I do not have xemacs variants installed so I would expect apt to select
"emacsen, psgml" as the required dependancies for xae. You can also see
that eieio has also been selected.

Please let me know if I can assist further.


-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux kaelor 2.4.6 #2 Tue Jul 24 23:12:22 EST 2001 i686
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8

Versions of packages apt depends on:
ii  libc6                  2.2.3-5           GNU C Library: Shared libraries an
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.010424 The GNU stdc++ library            

Reply to: