[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#50516: --download-only should ignore dependencies

Package: apt
Version: 0.3.14
Severity: normal

I cannot install pcmcia-cs because of dependency conflicts, but I expect at
least to be able to download it.

# apt-get -f --download-only install pcmcia-cs
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  pcmcia-modules-2.0.35: Depends: pcmcia-cs (= 3.0.0-9) but 3.1.4-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

(The above is transcribed by hand and may contain typos.)

I suggest that dependencies be ignored or at least overriden when only

Also, I don't know why it suggested using -f when I had.


-- System Information
Debian Release: potato
Architecture: i386
Kernel: Linux nolfolan 2.2.12 #1 Fri Aug 27 16:19:56 EDT 1999 i686

Versions of packages apt depends on:
ii  libc6                         2.1.2-10   GNU C Library: Shared libraries an
ii  libstdc++2.10                 1:2.95.2-3 The GNU stdc++ library            

Reply to: